I am running 12.04 with 3.2.0-57-generic-pae kernel on a Lenovo w520 that has a nVidia card in it. I updated yesterday, (17,December, 2013), and the update included the following two nvidia updates:

nvidia-current-updates:i386 (304.88-0ubuntu0.0.3, 304.108-0ubuntu0.0.1)
nvidia-304-updates:i386 (304.88-0ubuntu0.0.3, 304.108-0ubuntu0.0.1)

The error message I see is the same as someone else posted on another forum:

[ 29.393] (II) NVIDIA(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[ 29.393] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 29.393] (==) NVIDIA(0): RGB weight 888
[ 29.393] (==) NVIDIA(0): Default visual is TrueColor
[ 29.393] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 29.393] (**) NVIDIA(0): Enabling 2D acceleration
[ 29.402] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
[ 29.402] (EE) NVIDIA(0): system's kernel log for additional error messages and
[ 29.402] (EE) NVIDIA(0): consult the NVIDIA README for details.
[ 29.402] (EE) NVIDIA(0): *** Aborting ***
[ 29.402] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 29.402] (II) UnloadModule: "nvidia"

The answer given to them was to run the nvidia-config program and then restart the system. I do not have an nvidia-config utility on my system.

My question is how do I either back out these updates which caused the problem, is there another update currently available somewhere that will fix the problem, where can I get the nvidia-config utility to hopefully correct the problem, or what can I do to get back to where I can use the system with X functional?


The simplest fix for this involves purging the offending 'nvidia-304*' installation adn re-installing which will rebuild the kernel driver and correct the problem.

sudo dpkg -l 'nvidia*'

look at the versions currently installed.

sudo apt-get purge 'nvidia-304*'

This will remove all 304 related installs such as nvidia-current and nvidia-304-settings etc. and will remove the driver from the kernel. You need to do this with other versions if you have installed them to try and fix the issue e.g. 319

sudo apt-get autoremove

This will clean out any left over files

sudo apt-get install nvidia-current

This will install the current 304 release and related files e.g. nvidia-304 nvidia-304-settings etc.

Once complete

sudo reboot now

You should be good to go following a reboot.No removing of the ubunutu-desktop required.

Cheers Spart

  • This worked for me. Although I used the command: sudo apt-get remove --purge nvidia-* to remove all the drivers at once. The - is worth noting, in case you have any other non-driver programs by/for nvidia, without the dash, you might get some stuff you hadn't intended. – John T Jan 4 '14 at 9:53

I had the same issue. I can't be sure exactly what situation caused the problem, but I have my suspicions that having nvidia-current and nvidia-current-updates may have caused it. I certainly saw more than one nvidia driver installed when I did:

dpkg -l nvidia*

Fully removing all drivers and then reinstalling fixed it. To do that, enter these commands:

sudo apt-get -y purge --auto-remove nvidia.*
sudo apt-get update
sudo apt-get -y install nvidia-current-updates nvidia-settings-updates



First, I suggest you boot an older kernel from the grub menu.

Assuming the old kernel works, we can then debug your nvidia driver. But we need to know how you installed the nvidia driver (manually or from the software center?).

To configure nvidia, boot to recovery mode, start a root shell.

Remount the / partition rw

mount -o remount,rw /

then backup and re-run the nvidia configuration utility. It is a command line tool and I think it is called nvidia-xconfig, you can use tab completion

At the command line, type nvidia-TabTab and either the command will auto-complete or show a list of options.

cd /etc/X11
mv xorg.conf xorg.conf.backup

Then exit the root shell and continue a normal boot.

More likely then not, as the nvidia driver was working, reconfiguration is not going to help and you likely need to update your nvidia driver for the new kernel.

  • A previous kernel boot did not help. Same problem. – Doug Beattie Dec 19 '13 at 18:37
  • If booting an old kernel did not help, and if re-configuring nvidia (nvidia-xconfig) did not help, they you need to identify the nvidia card, make sure it is not a hardware problem, and debug the nvidia driver. – Panther Dec 19 '13 at 18:39
  • A previous kernel boot did not help. Same problem. As I mentioned before the only applicable things that changed would have been the following updates that I took using update-manager yesterday: nvidia-current-updates:i386 (304.88-0ubuntu0.0.3, 304.108-0ubuntu0.0.1) and nvidia-304-updates:i386 (304.88-0ubuntu0.0.3, 304.108-0ubuntu0.0.1). They appear to not be compatible with what was running on the system. – Doug Beattie Dec 19 '13 at 18:51
  • My /usr/lib/i386-linux-gnu/xorg/extra-modules/nvidia_drv.so file (which I believe is the commercial version from nvidia so that I can have accelration and combix working) was installed on Nov 5th and has a size of 7639352 with and md5sum of 96ab876fa4532414bc7130bfaf3f6248 nvidia_drv.so I did excute nvidia-xconfig (sorry as before I tried to do a nvidia-config which it could not find) but this did not work either. Is there a way to back out the two nvidia updates I took yesterday and retore to what was there before the update? – Doug Beattie Dec 19 '13 at 18:52
  • Sounds like you have yourself your very own bug =) To report see askubuntu.com/questions/5121/how-do-i-report-a-bug – Panther Dec 19 '13 at 18:53

After I removed the Nvidia drivers, I can get into X GUI. Although it is not a prefect solution, but it kind of works. Here are the commands to remove the drivers.

sudo apt-get remove --purge nvidia-*
sudo apt-get install ubuntu-desktop
sudo rm /etc/X11/xorg.conf
echo 'nouveau' | sudo tee -a /etc/modules
  • OK, problem is resolved. After removing the drivers, I manually install the new drivers again and it works. Here are the instructions to install the drivers. link – user227235 Dec 20 '13 at 9:47

protected by Community Jan 9 '14 at 9:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.