I had some problem when Ubuntu is booting.

After BIOS windows it trows this mistake:

Starting load fallback graphics devices [fail]

After this I see terminal with suggestions to enter login and password.

I couldn't figure out why this happen?

Here is my boot.log

It was started after I restarted PC.

I have NVidia video card.

By the way it has another trouble at /var/log/boot.log:

Starting vmware services\:
vm monitor          [fail]
vm communication... [fail]
vm socket family    [fail]

But I deleted all vmware product. And now this message is discard.

- How to solve this trouble?


I had same problem. After upgrading the nvidia drivers, it solved it.

  1. remove the existing nvidia driver :

    sudo apt-get purge nvidia-current

  2. updrage to the new driver: (follow this link)


    Here are commands I followed.

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

    sudo apt-get update

    sudo apt-get dist-upgrade

    sudo apt-get install nvidia-current

  • It will be nice if you mention a resume of those instructions from the link here. – user.dz Feb 2 '14 at 9:48

I had this problem too. I actually created it myself by installing nvidia-current (which is recommended by Chit in his answer) when trying to solve another problem.

I eventually discovered that nvidia drivers more recent than the 173.14.xx series would not work with my old card. I found the correct legacy drivers here:


So this is what I did:

wget http://us.download.nvidia.com/XFree86/Linux-x86/173.14.39/NVIDIA-Linux-x86-173.14.39-pkg1.run
chmod 755 NVIDIA-Linux-x86-173.14.39-pkg1.run
sh ./NVIDIA-Linux-x86-173.14.39-pkg1.run

Rebooted and it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.