3

I added a repository using sudo add-apt-repository ppa:tualatrix/next

After adding it i get the message:

gpg: keyring `/tmp/tmpk2n9xi/secring.gpg' created
gpg: keyring `/tmp/tmpk2n9xi/pubring.gpg' created
gpg: requesting key 0624A220 from hkp server keyserver.ubuntu.com
gpgkeys: key FE85409EEAB40ECCB65740816AF0E1940624A220 can't be retrieved
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

I even installed y-ppa-manger and tried importing all the keys. Got success message there but that doesn't solve the GPG key issue.

Thanks in advance for any help and suggestions!

  • How "new" is the PPA you added? When was the PPA created? Does it actually contain any packages? – Thomas Ward Dec 19 '13 at 14:47
  • Its the standard ppa for installing ubuntu tweak tool. So i guess it would be containing the required packages. – phineas Dec 19 '13 at 15:01
  • Its sudo add-apt-repository ppa:tualatrix/next instead of sudo add-apt-repository ppa:tualatrix/ppa. Sorry. But error is same. Writing mistake. – phineas Dec 19 '13 at 15:08
  • I just confirmed the key is on the keyserver, do me a favor and do this command and see if it downloads correctly (you do not need sudo for this command): gpg --recv-key --keyserver keyserver.ubuntu.com 0x0624A220 If it doesn't download right, then either your system isn't able to communicate with the keyservers right, or something else is up with your system. If all goes well, though, it'll return output similar to this – Thomas Ward Dec 19 '13 at 15:09
  • The key is not imported through this also. Getting the same message of key can't be imported. I am able to update using sudo so i think network should not be the problem.What could be the possible communication error with keyservers? – phineas Dec 20 '13 at 4:14
7

Try importing the key with :

sudo apt-key adv --recv-key --keyserver keyserver.ubuntu.com FE85409EEAB40ECCB65740816AF0E1940624A220

If it doesn't work try with :

sudo aptitude -o Acquire::http::No-Cache=True -o Acquire::BrokenProxy=true update
  • 1
    This doesn't work. Same message – phineas Dec 19 '13 at 14:17
  • 2
    The first one worked for me. I had this problem while trying to install docker – Christian Bongiorno Aug 19 '15 at 20:12

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.