I have a sony vaio duo 11 convertible, it was successfully dual booting lubuntu 13.10 and windows 8, but after the upgrade to windows 8.1 it doesn't load anything but windows.

I disabled windows' "quick boot" feature, then run boot-repair, but it doens't fix the issue (it used to work when windows 8 messed the boot config, but not with windows 8.1). I installed esayBCD on windows and now I see its boot loader, but not grub. I even tried chrooting and grub-installing on /dev/sda, but I don't think that grub is the boot loader loaded at startup.

My guess is that windows put a boot loader somewhere else than /dev/sda.

If I start the system with a refind USB disk I can successfully load lubuntu.

This is boot-repair output: http://paste.ubuntu.com/6598795/ (this one was run after booting sda2 lubuntu from a refind usb disk, but I also tried with live CDs with the same results)

A brief history of how I got there:

  • In BIOS, I disabled "secure boot" and enabled "UEFI mode".
  • Formatted the hard disk to wipe the sony pre-installed windows 8
  • Installed Lubuntu 13.10 on sda2 (sda1 was created by the installer as UEFI partition)
  • Installed Android-x86 on sda3 (everything was working so far)
  • Installed Windows 8 in the free space (it created sda4-5-6). Windows screwed up the boot, but boot-repair fixed it. Windows kept overwriting the boot loader until I removed its "quick boot" option. (everything was working again)
  • Upgraded windows to 8.1, now there is a windows boot loader, I removed (again) the "quick boot" option, I repeatedly installed grub on /dev/sda but I always get another bootloader (windows/microsoft/easyBCD??) that is only able to run windows.

I would like to understand which boot loader is run at startup, where it is located, and how I can change that. Thank you!

edit: I installed rEFInd in windows following the official instructions, and effectively changing the "windows boot manager" section so that now it looks as follows:

S:\EFI\refind>bcdedit /enum active /v
Windows Boot Manager
identificatore          {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=S:
path                    \EFI\refind\refind_x64.efi
description             rEFInd am
locale                  it-IT
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {b781b519-6749-11e3-a4a1-eb3a69ac7fb1}
resumeobject            {b781b518-6749-11e3-a4a1-eb3a69ac7fb1}
displayorder            {b781b519-6749-11e3-a4a1-eb3a69ac7fb1}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 5
displaybootmenu         Yes

BUT I still get a boot loader that is not rEFInd!! it looks similar to this instead: windows legacy boot loader



In Win 8.1 hold down SHIFT while you click on Restart. It should bring Advanced Startup Options. You should be able to select your Ubuntu startup partition from there and then boot into it.

Saves the trouble of re-installing, but you have to ask Windows to load Ubuntu...


Your Boot Repair output shows that there's no BIOS/CSM/legacy boot loader installed, so it's unlikely that the screen you're seeing is for that. It's more likely to be the Windows EFI-mode boot manager.

You've taken all the right steps, so it's puzzling why it's not working. Your symptoms, though, are mostly consistent with a computer on which Secure Boot is enabled, so to start with, I recommend you check your firmware's Secure Boot settings. Maybe it got turned back on after you disabled it, or maybe there's something odd about the setting that you overlooked. (OTOH, the fact that you can boot with a rEFInd USB flash drive argues against this possibility. Still, it's worth checking....)

If that doesn't work, you might consider a rather radical approach (but do this only if you can currently boot Linux via a rEFInd USB flash drive):

  1. Launch Boot Repair and use the Advanced menu to select the option to restore backups. Your Boot Repair output indicates that these options have been applied, but they may be causing some confusion, so it's best to undo these changes.
  2. Back up the ESP. (Simply copying the /boot/efi directory tree to a spare USB flash drive or some convenient directory in Linux should do the trick -- but a USB flash drive will be accessible under Windows, should that become necessary.)
  3. Delete all the files on the ESP.
  4. Using efibootmgr or your firmware's tools, erase all the firmware's boot manager entries from NVRAM. You'd do this by typing sudo efibootmgr -v to see what the entries are, then using the -B option and -b #### to delete each entry in turn, as in sudo efibootmgr -B -b 0001 to delete Boot0001. You'll need to repeat the -B/-b command for each entry.
  5. Re-install rEFInd in Linux. (Alternatively, you could re-install GRUB 2 with grub-install.)
  6. If rEFInd boots from the hard disk, and enables you to boot Linux, try restoring the EFI/Microsoft subdirectory.

The idea here is to clean all the crud out of the ESP and the NVRAM, thus enabling you to start with a clean slate.

  • Thank you Rod Smith. At the moment I can't try what you suggest because I fear that after that I risk not being able to run Windows, and I need it in the next few days (afterwards I could try). I can confirm that "secure boot" is disabled - and in fact if I enable it I can't boot refind from USB.
    – ale dino
    Dec 19 '13 at 17:48
  • If I run sudo efibootmgr -v from linux, there is only one entry, and that is "EFI USB Device". That is probably because to boot from USB I have to start the pc with a special key and then select boot from usb. I guess that it temporarily overrides the NVRAM content. So I can't delete entries, and if I do add entries, they disappear the next time I boot.
    – ale dino
    Dec 19 '13 at 17:48
  • If you can boot Windows from rEFInd launched from the USB flash drive, then my suggested radical procedure poses little risk; just be sure that you've got a backup of the EFI/Microsoft directory on the ESP so that you can restore it. (You'll need that to boot Windows.)
    – Rod Smith
    Dec 20 '13 at 22:57

I solved the issue this way:

  • Start lubuntu from refind usb boot disk.
  • Delete everything in /boot/efi
  • mkdir /boot/efi/EFI (otherwise boot-repair doesn't realize that there's an EFI partition)
  • boot-repair selecting the option "separate /boot/efi" partition.

At this point grub works and boots lubuntu (and android-x86).

To get windows back, I had to restore the folder /boot/efi/Microsoft, then rename it to Microsoft2 and add this to /etc/grub.d/40_custom :

menuentry "Windows Boot Manager (UEFI on /dev/sda1)" --class windows --class os {
    insmod part_gpt
    insmod fat
    set root='hd0,gpt1'
    chainloader /EFI/Microsoft2/Boot/bootmgfw.efi

I had to rename the folder because strangely if there is a folder named "Microsoft", the windows boot loader is shown instead of grub (and I would really like to know why).

  • The latest windows update disrupted the boot process again. I had to follow this repair procedure again (deleting the boot/efi/Microsoft folder). I guess that the only way to get definitely rid of this problem is to uninstall Windows and wait till Microsoft will decide to make their product play nice with other operating systems.
    – ale dino
    May 2 '14 at 9:16


Sorry about the length of this answer but it's what worked for me.

I'm also working on finding a way to add the Ubuntu boot file the EFI drive boot folder. I'll post here if I get it to work.

  • Ok so after about 9 hours of trying to install Lubuntu on my laptop that has Windows 8.1 I have figured everything out except how to have an automatic option between OS's when booting. So, here's what I have learned:

    • The steps I'm sure most already know but I'll go through them anyways:

Part #1 ~ Download Software & Install on USB Drive

  • Download the Ubuntu (for desktop PC) or Lubuntu (for laptop PC) .iso file.

    • Next you need to create a liveCD or liveUSB of the .iso. so we can boot from that when done.
    • Download Unetbootin selecting the run feature. Once the install is complete start the program. I shouldn't have to say this but we all have these moments so: Make sure your USB is in your computer LOL. Next check that your USB has enough room for what you're doing. Everything I've read says to use an 8GB USB (for Lubuntu) so that's what I did and it took up 0.6GB and I have a hard time believing it needs 7GB to run. However, if your installing Ubuntu, I'd say you probably want to use an entire 8GB USB just to be safe.

      1. Once it's running change how it's getting the iso by clicking the bubble next to the DiskImage
      2. Next click the link with 3(three) dots on it and find your file on you computer wherever you saved it.
      3. Lastly check that it has selected the correct USB (If you have more than 1(one) connected) and click OK to begin installing it on your USB

Part #2 ~ Partition Hard Drive for Ubuntu Installation

  • Now you need to partition your HDD, if you don't have a partition software MiniTool is a good freeware you can use, and it's what I'm going to describe here and use pics of. So if you need to download that now. The size of your partition drive doesn't need to be big (I used 13GB, 10GB for the operating drive and 3GB for the swap drive). As before with the USB if you're planning to install Ubuntu you'll probably want to allocate more space for the root HDD you choose.

    1. After installing MiniTool the first screen asks for permission, click yes, the next screen has 02 choices: MiniTool Partition Wizard and MiniTool Power Data Recovery. Naturally you'll select the partition wizard. Now don't be intimidated when the home screen appears, it's not as difficult as it looks.
    2. Now you'll create the room for your partition. If you have unallocated space on your HDD (Yeah. Right. Who has that?) then skip ahead to Step 4. If you don't have any unallocated space, the best thing to do is choose your main HDD location (C:\ unless your computer was custom built and you requested otherwise) and use a portion of that for your new partition. If you're reading this part I'm going to assume you're new to the world of partitioning so you don't have a partitioned drive with a separate storage partition and operating system partition. If you have 2 HDD's just choose the one with more free space. Also you'll more than likely notice your HDD already has other partitions that aren't mounted (don't show in Windows) and one that is. It's just the manufacturers way of making sure people don't delete important stuff, so try not to format or alter these drives in any way.
    3. After choosing the correct location to create your new partition from (make sure it is the one highlighted in the brownish color), at the top of the window there are different options. You want to select Move/Re-size. When the new window appears the first thing you'll probably notice is the bar that represents the drives current size. What you want to do is click & hold the right side of that bar and drag left freeing as much space as you'd like. Say you have approximately 371GB free & a total size of 627GB and want Ubuntu to be free standing (not sharing any HDD space) so you want it to have a 150GB partition. You would drag the bar until it was as close to 477GB as possible (If you're OCD like me you can use the value size boxes under the bar until you get your desired sizes). The data info in the bar is in GB however the value boxes are in KB so remember that 1024KB = 1GB. Now click OK
    4. Now you'll see a section of unallocated HDD space (If you skipped to this step we I have created an imaginary partition with 150GB of space). Now select the unallocated HDD space (gray) and click the option create partition. Use the slider to determine the size of this partition (I recommend creating your data drive first so you can merge it later with your C: drive if you need to). Assuming you're installing Lubuntu the recommendation is your SWAP drive be the same size as your computers RAM, I have 3GB so I'm going to use that. You'll want 10GB for your OS and the 3GB for your SWAP, therefore your first partition should be 137GB. Before or after adjusting your slider you can name the drive, I'll name mine Steve.
    5. You also choose the format here, from the research I've done it seams Ext3 is the best. If you're new to Linux, you're probably no familiar with this format and that's because it's just for Linux. If you think you'll want Windows to have access to this drive or might have to merge them later and don't want to have to format the drive and lose the info on it u can choose NTFS.
    6. Now you pick the Drive Letter, use the drop down list and take your pick. This have no impact on the drive itself. Since mine is named Steve I'd make it the S: drive.
    7. Leave the cluster option at default and click OK
    8. This will take you back to the home screen with a remaining unallocated section of 13GB, repeat Steps 4-7 using a different name and Drive Letter, however you can't use NTFS here. Use the Ext3 that I talked about earlier.
    9. Now that it's all setup for your l/ubuntu installation you want to click Apply in the top left corner.

Part #3 ~ Changing Your Computers Setting

  • After MiniTools has finished creating the partitions it's time to adjust your BIOS/UEFI settings. There's 2(two) ways of doing this.

    • If you're familiar with Command Prompt or Power Shell open one. If not you can right click the start icon on your task bar and select Command Prompt and when it opens type (shutdown /r /o) without the parenthesis, if it doesn't, add an .exe extension after "shutdown". When done correctly your computer will reboot into the advanced settings menu. If you aren't comfortable with this I'll tell you the long way.
    • For the long route hold the Windows key and hit C to bring up the charms bar or move your mouse to the top right corner of the screen and open the settings sub-menu.
    • Select Change PC Settings at the very bottom of the menu. In this settings menu go to the bottom sub-menu Update & Recovery, once in this menu again select the bottom sub-menu recovery and lastly click the restart option in the bottom category Advanced Startup
    • Your computer will now restart into the Advanced Start-up menu. You should have 3 options, select Troubleshooting and then select the UEFI Settings Menu again your computer should restart. This time into a menu set that looks just like an old BIOS settings menu. Here is where it can get a little tricky, each UEFI menu is different depending on what kind of motherboard you have. If you don't know what you're doing I wouldn't recommend changing anything besides what I talk about. Changing the wrong thing in this settings menu can ruin your computer beyond repair. If you have a computer or laptop from a major manufacturer (Dell, HP, Gateway, Etc.) they probably locked most of the settings anyways but a few (ASUS, Alien) don't and if it's a custom built computer it'll probably be fully adjustable.
    • Anyways go to the BOOT menu/sub-menu, you might have to use the arrows on your keyboard and it might be a sub-menu. The BOOT menu is actually a sub-menu of the System Configuration menu. Once in the BOOT sub-menu you should be able to adjust a few things no matter what kind of computer you have. One of which is the order your computer checks drivers to boot in. This means if the OS software is first on the list the USB won't work. You'll want to move the USB drive option to the top of the list. Here is where I found a way to boot with Lubuntu, if you ever used the old BIOS menu you know that you entered by hitting either the ESC, DEL, F2, or F9 keys, this isn't a standard option anymore however my HP Pavilion Sleekbook 15 has an option called POST Hotkey Delay to turn this feature on and pick how long you have to push the key.
    • If you have this feature it's not the same as the old BIOS, on my computer when this feature is on and I push the ESC key, instead of going directly into the BIOS menu I'm given an option list that includes a way to pick my boot device, go into the BIOS menu, and a few other options I can't remember.

I had to turn OFF "Fast Boot" option in my BIOS and that worked.

I left the fast boot option ON in the Windows 8.1 and also left the UEFI and Secure boot options on in the BIOS. My setup was Windows 8.1 Pro and Ubuntu 13.10. I also tried Debian 7.3 and it was giving me the same problem until I made the above changes to the BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.