2

I have recently acquired an old computer that I tried to install Ubuntu 12.04.3 server onto, however the system could not be booted into any external medias (USB and CD drives). So I hooked the hard drive into another computer of mine and installed the OS, then when I booted the server up it could not ping any web address or DNS from the internet. I narrowed the problem down to the fact that the Ethernet port has not been configured. to back this up I ran:

ifconfig -a | grep eth

and the result was:

eth1     Link encap:Ethernet   HWaddr 00:08:74:c3:2f:df

next I ran:

ifdown eth1 && ifup eth1

and the result was two lines. the first line result was:

ifdown: interface eth1 not configured

and the second line read:

Ignoring unknown interface eth1=eth1

I just need to get this connected to the internet, but it is not enabling the Ethernet port, are there any commands that will enable me to manually activate the Ethernet so I can get internet connection?

The machine is a Dell Dimension 2350.

2

I assume, since you are running Ubuntu Server, that you are running without a graphical environment. First, verify that your ethernet inteface is actually eth1:

ifconfig

Configure the interface temporarily:

sudo nano /etc/network/interfaces

Add the following lines at the bottom of the existing file:

auto eth1
iface eth1 inet dhcp

Save and close nano. Now try to get an IP address:

sudo ifup -v eth1

Did you connect? Confirm:

ifconfig

For a server, so that you can ssh and ftp to the machine, I suggest you use a static IP address. Check in the administration pages of your router or access point to find the range of addresses used for DHCP; select an address for your static server outside that range. Now that we know that the Dell connects, let's reconfigure for a static IP:

sudo nano /etc/network/interfaces

Change the eth1 lines to:

auto eth1
iface eth1 inet static
address 192.168.1.125
netmask 255.255.255.0
gateway 192.168.1.1
dns-nameservers 8.8.8.8 192.168.1.1 

Save and close nano. Usually, the router address is fine for DNS. You may add other, faster servers if you wish. Substitute your settings here as needed.

Get the system to re-read the file and use the changes:

sudo ifdown eth1 && sudo ifup -v eth1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.