1

Where can I set services apache2 and mysql to do not start automatically? Or start when asked for it instead?

EDIT

BootUp-Manager worked for me very well disabling autostart of both services.

1
  • Have you looked at this question? I know it's the opposite, but it will give you a hint on where to look. Check the man page as they say in the answer, askubuntu.com/questions/9382/… – Alvar Dec 19 '13 at 3:27
1

Ubuntu uses both sysvinit as well as upstart for runlevel.

What you can do for apache2 as I think apache2 doesnot have upstart configuration is:

update-rc.d -f apache2 remove

and for mysql. You need to edit /etc/init/mysql.conf

Search for line start on and comment it with #

#start on runlevel [2345]

Basically scripts and configuration which are started are located on

/etc/init.d/

/etc/init/

/etc/init/ is for upstart configuration

Also you can use BootUp-Manager [Graphical Application] to disable services of /etc/init.d/ but I donot think it works for /etc/init/

Just do:

sudo apt-get install bum

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.