Nautilus won't start when i log in, the CPU usage is high without showing what's using it. After killing the nautilus processes a couple of times it starts working again.

I got problems with Ubuntu One too. "File Sync error. (org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus))". And, the sync option in folders is gone.

Both errors appeared at the same time. I've tried to update, but no updates is available.

  • Did you use nautilus scripts? If you use nautilus scripts, just uninstall them. I have faced this very problem before – user May 3 '11 at 14:58
  • No, I don't. I guess I have to reinstall Ubuntu :( – Alex May 10 '11 at 21:33

I wouldn't reinstall Ubuntu in order to fix this problem.

Instead take unshare any folders Ubuntu One sync-daemon is attempting to sync. If this doesn't work try killing the ubuntu-one syncdaemon. Check what resources this is using in System Monitor. If the process keeps coming back and causing Nautilus to crash you can uninstall Ubuntu One with the following actions:

Go to System->Administration->System Monitor.

Switch to the Process tab, and you should find out anything that begins with "ubuntuone". Choose them, and click "End process".

Go to Applications->Accessories->Passwords and Encryption Keys.

If there is a token for Ubuntu One right-click it and choose "Delete" / Mine was actually called "default".

Go to Applications->Accessories->Terminal to open a terminal window. Type the commands below:

rm -rf ~/.local/share/ubuntuone
rm -rf ~/.cache/ubuntuone
rm -rf ~/.config/ubuntuone
rm -rf ~/Ubuntu\ One

You should enter the following commands in terminal:

sudo apt-get purge ubuntuone-client* python-ubuntuone-storage*

Now your Nautilus problems at least should be resolved.

  • Thanks to damon365 :) I had the same trouble as the OP, and the described solution worked for me. I was almost going bananas with this stupid nautilus<->ubuntuone-syncdaemon bug. I tried soo many things to get solve this problem, it seems that nautilus is FAR from perfect and needs some serious stability improvements. The same is the case with Ubuntu-ONE. This service is a great idea but it is not very reliable and I had loads of trouble with it in the past, not getting it to do what I wanted to. The increase from 2 GB to 5 GB of userspace is another ubuntuesque glitzy update that doesn't incr – user22410 Jul 28 '11 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.