I've been trying to install Adobe Air on my 64 bit Ubuntu machine. The first thing I tried was to follow this tutorial that symlinks the missing libraries, but it is under the impression that HAL was still available, so I then had to follow this guide to get HAL working. Now my issue is that when I try to run ./AdobeAIRInstaller.bin, it tells me that it can't find libgtk-x11-2.0.so.0 because of 13.10's folder structure (libraries aren't simply in /usr/lib anymore, they're sub-foldered by build). I then tried to make a symlink from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0 to /usr/lib/libgtk-x11-2.0.so.0, but lo and behold, we need it to be a 32 bit library, says the linker:

/tmp/air.RYKQLa/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: wrong ELF class: ELFCLASS64

I can't seem to find the package libgtk-x11 in Synaptic, and sudo apt-get install libgtk2.0-0:i386 didn't get the right library. Is there a way around this or a way to get libgtk-x11-2:i386? Thank you in advance!

  • Is libgtk2.0-0:i386 installed? It is if find -name /usr/lib 'libgtk-x11-2.0.so.0' 2>/dev/null returns something. – Richard Dec 19 '13 at 0:19
  • Yeah, I already tried that. – Athan Clark Dec 19 '13 at 0:23
  • I know I already installed it through apt-get, but it didn't include libgtk-x11:i386. I can't even find the package on Synaptic. – Athan Clark Dec 19 '13 at 0:32

Since you said libgtk-x11-2:i386 is installed (via apt, which doesn't lie, usually), you should symlink to /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0:

cd /usr/lib
rm ./libgtk-x11-2.0.so.0
ln -s /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
  • Nonono, only the 32 bit version is installed. Miraculously, the 32 bit version appeared out of thin air, though. I wish that I could have found how I solved the problem. – Athan Clark Dec 19 '13 at 0:47
  • Synaptic only deals with the package names, and doesn't pay attention to the architecture suffix (:i386 and :amd64), like apt can. – Richard Dec 19 '13 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.