3

I know this has been asked before, but I can't find an answer that also pertains to this /tmp message. I have 12.04 LTS on a Toshiba laptop, as well as Windows 7. I really just started to dig into Ubuntu on here, and so I barely have anything on the system. At this point I use Ubuntu for XBMC streaming, and anything VPN related.
For the past few months everything was fine. Last week I started to theme it with icons and borders.... that's the only thing I've done. Shortly after, I get this message regarding /tmp drive. I just wait the 5 seconds and let it boot, but I'm curious what's going on. What I could have done to make this happen now. After it boots, everything works fine. Everything shows healthy in G parted. I see this question asked a dozen times, but a dozen different answers in search. It would be great to not only fix it, but figure out how it happened. Thanks

G parted

EDIT: I see on Ubuntu Forums someone tried mount -o remount, rw / Can I try that now, or would I have to restart, press M for manual, then type command in terminal?

2ND EDIT: Here's what I get after cat /etc/fstab

mike@Mike-Ubuntu12:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=71d51bdc-9bd4-4897-85fb-c08d68620d4b /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=58a3a8ae-eb46-459c-9464-47cfa932b498 none            swap    sw              0       0

ALSO, I get this TMP message sporadically. I booted my computer twice today and have not gotten this message (so I don't know if the fstab even helps) But I got the message yesterday.

Edit: blkid and fstab in Gedit Gedit screenshot

2
  • Add your /etc/fstab to your question. – psusi Dec 18 '13 at 22:54
  • I finally got a day to myself, and a chance to focus on this. I added /etc/fstab. Thanks – 5th Wheel Dec 28 '13 at 16:18
2

It can be related to : https://bugs.launchpad.net/ubuntu/+source/mountall/+bug/1091792

You need to reboot and press M for manual to run mount -o remount, rw /, but I think it won't solve your problem on it's own. You should run a fsck on / (or /tmp if it's a separated filesystem from /).

Did you upgrade your ubuntu recently? If yes you should also try to apt-get install -f repair all packages. (maybe some packages from installing themes are broken)

4
  • 1
    No, I haven't upgraded. I installed 12.04 a few months ago, and stayed with it. To run " fsck " , could you explain the steps, or is it a specific code for terminal :ie / fsck (or something) Thanks – 5th Wheel Dec 18 '13 at 21:06
  • - Reboot the system - When "The Disk Drive for /tmp is not ready yet. S to skip mount or M for manual recovery" appeares press M - mount -o remount,rw / – user226762 Dec 18 '13 at 21:13
  • And then run apt-get install -f first. – user226762 Dec 18 '13 at 21:23
  • 1
    Ok thanks. Strange, I just restarted my computer and the message did not appear this time. It booted straight up. So, I don't know. – 5th Wheel Dec 18 '13 at 21:32
1

you need update fstab. simple way:

  1. Open terminal.(i say first terminal)
  2. in terminal write sudo blkid.
  3. every partition has an UUID,don't close this terminal and go to 4.
  4. right click on terminal and open Terminal or New Tab.
  5. in new terminal(second terminal) write sudo gedit /etc/fstab.fstab file opens.
  6. the UUID that appears in fstab should be same UUID that appears with sudo blkid.if any UUID in fstab differs ,you should copy it from first terminal on fstab.
  7. save and exit .
  8. restart to see result.

Hope this helps!

2
  • I posted a screenshot, but to me, the UUID in sda5 and sda6 match on both. I still get this message at boot up, but only sometimes. And I just wait an added 10 seconds and it boots fine. – 5th Wheel Jan 5 '14 at 18:34
  • excuse me,my answer is for ntfs drive – Rouhollah Torshizi Jan 14 '14 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.