I bought a Dell Vostro 2520 two days back and when I clicked wifi icon to connect to my wifi network, I couldn't see mine or any other wifi networks. So I then realized that I need to install a driver so that I can connect to my Wifi network which is Broadcom STA wireless driver. I tried activating it but then an error came on the screen that said

Sorry, installation of this driver failed. Please have a look at the log file for details: /var/log/jockey.log

So then, I tried connecting to my wired connection. But there are a few problems.

I clicked on IPv4 Settings and set the method to Automatic (DHCP). I could get my IP Address and my Netmask but not my Gateway address and my DNS server.

I tried getting my Gateway address by Terminal but all the answers were blank so I couldn't get my Gateway Address.

Kernel IP routing table

Destination blank Gateway blank Flags Metric Ref Use Iface

I also can't get my DNS server cause I have no internet connection. I tried everything I googled to resolve this problem but nothing seems to work. All I'm getting are errors.

Okay so now the Wired connection shows that it's connected but it's not connected. I did the command @chili555 told me to and here is what it says:

07:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RT8111/8168/8411 PCI Express Gigabit Ethernet controller Controller [10ec:8168] (rev 07)

Now that my Wired connection shows that it's working but it's not, I got my Gateway address and my name server. I added them in my wired IPv4 settings. But my internet connection isn't working still. :(


YAY! It's fixed!! Wired and wireless connections are fixed! Thank you so much! :D

  • Please edit your question to add details of your wireless and ethernet card: lspci -nn | grep -e 0200 -e 0280 – chili555 Dec 18 '13 at 22:42
  • @chili555 done! – Bardia Dec 20 '13 at 11:15

You shouldn't need to add any settings at all to the IPv4 section in Network Manager. If some have been added, please remove them. Be sure Infrastructure and Automatic (DHCP) are selected. Then, with the ethernet cable attached, simply click the Network Manager icon and try to connect. Confirm:


Do you have an IP address? Can you reach the internet?

ping -c3 www.google.com

Once you are connected, let's try to fix the wireless.

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source

If the install fails again and asks you to consult the log, please do:

cat /var/log/jockey.log

Paste the outcome here and give us the link in your reply: http://paste.ubuntu.com/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.