0

I want to run mev (On Ubuntu 12.04 LTS) but it is part of the package gpm which I don't have. I tried running:

sudo apt-get install gpm 

And I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package gpm is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'gpm' has no installation candidate

It should be in the standard ubuntu sources as far as I know. It was listed in Ubuntu software centre but failed to install. After an apt-get update it is now listed as "missing" in the software centre. Any ideas?

  • Silly me, didn't say! 12.04, updated above! – Julian Stirling Dec 18 '13 at 16:38
  • what was the error shown wile you installing it from SC? – Avinash Raj Dec 18 '13 at 16:39
  • Stupidly I never saved the original error. It was something about can't find package (perhaps "failed to fetch"). It made me think running apt-get update would solve it. That is all I remember unfortunately :( – Julian Stirling Dec 18 '13 at 16:41
3

gpm is in the universe repository.

using any method, enable the universe repository , then run

sudo apt-get update && sudo apt-get install gpm
| improve this answer | |
  • Universe is on (and so is multiverse) I have also tried changing server from Romanian server to the main server. (Updating each time) – Julian Stirling Dec 18 '13 at 16:53
  • gpm is in the repository, I can see the file in the mirrors. packages.ubuntu.com/lucid/i386/gpm/download and packages.ubuntu.com/lucid/amd64/gpm/download so, my only other suggestion is to use another mirror and to confirm the package is in the mirror you use. You can also post your repositories. – Panther Dec 18 '13 at 17:04
  • I turned the repository OFF, updated. Turned it back on updated AGAIN. Magically sprung back to life. Who knows what was up there!? – Julian Stirling Dec 18 '13 at 18:00
  • Glad you got it sorted. – Panther Dec 18 '13 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.