I just upgraded to Ubuntu 11.04 from 10.10 using direct Internet connection and now just new looking desktop (with the Launcher on the left) is shown and system hangs. Mouse cursor is moving but clicking icons and keyboard shortcuts have no effect. Maybe something went wrong during upgrade procedure. you know, It did not finished correctly; at the last seconds of installing upgrades it gave an error saying "it can not acquire lock" and exited. I just manually clicked "restart to complete upgrade" from the menu. I run the upgrade routine again but it says the system is upgraded.

No shortcut key works, (I hit win key or Alt+F2 but the result is nothing). Yes, Caps lock is working. I mean that when I press it the Caps Lock light turns on). I am sure that there is no special process that makes CPU busy, mouse cursor is moving so fast and my CPU fans are in normal mode and does not make loud noise. I boot in Recovery mode and typed the upgrade command and as I said it says that the system is already upgraded. You know, the situation is very similar to a state that you have a window in front and clicking items in the background has no result. I haven`t installed Ubuntu from wubi.

  • Is your ubuntu installed with wubi????? – MrMassiveManMeat May 2 '11 at 19:14
  • No, It is a seprate OS and appears in Grub. – Ramin May 2 '11 at 19:56

The problem was because of the unity desktop (it is the default view in Natty). I just selected Ubuntu Classic as the default session from System Settings -> Login Screen Settings and now the old desktop is OK. Tnx

  • Good you found your way out! – Ubuntuser May 3 '11 at 15:51

Are you able to bring up the dash using the super key (windows key)? or using Alt +F2? Are the Caps Lock and Num Lock keys working? If it is very slow in showing up, then i guess some process is slowing down everything in your system . The main culprit would be compiz or X.org. Try checking your system's processes by typing top in a terminal window. This will show you what application is using the most cpu. If you see its comiz using the most memory, try typing compiz --replace & in a terminal window

You may also try to run an upgrade command.

sudo apt-get update
sudo apt-get dist-upgrade

See if that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.