I'm trying to upgrade my Ubuntu release from 12.10 to 13.04, having successfully upgraded to 12.10 yesterday. With the intention of then moving to 13.10.

I am up to date with other software updates.

Using the Update Manager I am offered to upgrade the release, but this is offering an upgrade to 13.10 instead of the expected 13.04.

When selecting upgrade this does in fact attempt to upgrade to 13.10 'Saucy', the application tells me off for doing so, rightly so, and sends me away.

Any ideas how I can upgrade to 13.04 firstly?

  • If you are being offered 13.10 then you must be on 13.04. You also can't directly upgrade from 10.10 to anything but 11.04, both of which have been end of life and unsupported for some time, preventing upgrade unless you go out of your way to enable the obsolete repository.
    – psusi
    Dec 17, 2013 at 23:38
  • Hi psusi, thanks for your response. sorry advised incorrectly previously, i am actually on 12.10, having checked on terminal following release info provided: Distributor ID: Ubuntu Description: Ubuntu 12.10 Release: 12.10 Codename: quantal
    – Lee
    Dec 18, 2013 at 20:59

5 Answers 5


You have to use update-manager-core from quantal-updates instead of quantal-proposed.

See: I don't know how to upgrade 12.10 to 13.04 or 13.10

  • Andreas - thanks for your answer, worked a treat. updated to 13.04 as suggested using update-manager-core. Then 13.10 via update-manager. Many thanks.
    – Lee
    Dec 22, 2013 at 16:10

The definitive situation around this is that the update-manager package does not support upgrades to saucy .. well, as of today.

Maybe it did so in the past, and maybe it may do so again in future. But as of April 2014 this tool does not support upgrades to saucy. Perhaps this may be on account of the EOL'ing of Raring (13.04) .. and perhaps also the need for a direct upgrade from 12.10 to 13.10.

The only thing that worked for me was:

  • s/quantal/saucy/ in /etc/apt/sources.list
  • apt-get update
  • apt-get dist-upgrade

This will what you should do:

sudo apt-get -y dist-upgrade

this will upgrade all of your dependency files, easier that way before upgrading to Saucy. This next command will enable you to move on up to Saucy:

sudo do-release-upgrade

then that will fire off the process. Good luck!

  • Hi Faron, cheers for response. I have attempted this but following error message is returned after 'sudo do-release-upgrade (ps I advised incorrectly about what version i was currently on previously): Cannot upgrade An upgrade from 'quantal' to 'saucy' is not supported with this tool.
    – Lee
    Dec 18, 2013 at 20:57

This is expected, but not so early. Raring will be EOL (End Of Life) from January 2014 onwards, but Quantal (which you are using) will be still supported until April 2014. So, what the release team did:

So instead the supported upgrade path will be 12.10->13.10->14.04, starting from January.

You might be feeling this. They probably (I haven't found the sources yet) activated this from the server side before hand. I don't know if such behavior could be tweaked (from client side) and I wouldn't experiment with it. You can try the upgrade, if it works, great! If it doesn't, please report a bug. Make sure to make backups of all your stuff before upgrading!


  • Hi Braiam, attempted the upgrade and error returned: lee@lee-Aspire-5720:~$ sudo do-release-upgrade Checking for a new Ubuntu release Get:1 Upgrade tool signature [198 B] Get:2 Upgrade tool [1,135 kB] Fetched 1,135 kB in 0s (0 B/s) authenticate 'saucy.tar.gz' against 'saucy.tar.gz.gpg' extracting 'saucy.tar.gz' Reading cache Checking package manager Cannot upgrade An upgrade from 'quantal' to 'saucy' is not supported with this tool.
    – Lee
    Dec 18, 2013 at 22:51
  • "An upgrade from 'quantal' to 'saucy' is not supported with this tool" I think this may be the problem. Try with update-manager instead.
    – Braiam
    Dec 18, 2013 at 23:00
  • update manager is displaying the same error when attempting to.upgrade. it shows I'm on 12.10 advises a new version 13.10 is available but then returns this error. I'm in no rush to get this sorted, so will hang on until janary when 13.04 is officially EOL and failing.that a clean install to 13.10
    – Lee
    Dec 19, 2013 at 9:27
  • @Braiam Please see my answer here: askubuntu.com/questions/390587/… for one solution to the "is not supported with this tool" issue.
    – intgr
    Feb 17, 2014 at 15:56

I had the same problem and this is how I managed to upgrade 12.10 to 13.04 instead of 13.10:

1) Open release-upgrades file: sudo gedit /etc/update-manager/release-upgrades
2) You should have Prompt=normal, this mode upgrades to release that immediately succeeds the currently-running release.
3) Run upgrade using sudo do-release-upgrade

This way I now have 13.04, not 13.10.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .