2

I have the following in my rsyslog configuration. It works well.

:msg, contains, "<switch2>" /var/log/switch.log
& ~

I need to disable RepeatedMsgReduction for log messages that are routed by this rule, while leaving it enabled for all other messages.

How can I do this?

(originally asked in ServerFault but no responses)

-2

Edit /etc/rsyslog.conf

and change RepeatedMsgReduction from on to off.

  • This answer doesn't meet the OPs original specification of "leaving it enabled for all other messages." – Rick Chatham Mar 17 '15 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.