1

I am using a Winfast Leadtek TV 2000 XP card and TVTime 1.0.2 to watch analog TV. The TV card's sound output is hooked up to the CD-in of my mainboard (MSI Intel X58 Platinum).

Just recently I managed to get ALSA to correctly recognize the CD-in (see How do I enable CD-in?).

Now I would like TVTime to adjust the ALSA CD slider when turning the volume up and down in TVTime. However, TVTime refuses to do this and I always have to use alsamixer to control the volume.

I have tried different settings for the MixerDevice setting in the tvtime.xml configuration file as suggested e.g. in https://askubuntu.com/a/217462/9598. When using this value, this is the output when running TVTime:

Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/chrisipk/.tvtime/tvtime.xml
ALSA lib control.c:953:(snd_ctl_open_noupdate) Invalid CTL 
mixer: attach error: No such file or directory
mixer: Can't open mixer , mixer volume and mute unavailable.

This is what I currently have:

<option name="MixerDevice" value="default/cd"/>

This is the output when running TVTime:

Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/chris/.tvtime/tvtime.xml
mixer: find error: Success
mixer: Can't open mixer default, mixer volume and mute unavailable.
mixer: Can't open device default/cd, mixer volume and mute unavailable.

The current setting seems to be somewhat right as the output no longer complains about missing a file or directory and contains "find error: Success".

What do I need to do so that TVTime can adjust my CD-in volume?

5
  • Did you already try this? askubuntu.com/questions/45357/… Please pay special attention to the place where I explain sound issues or no sound, which may be corrected by dropping tvtime | arecord -D hw:1,0 -r 48000 -c 2 -f S16_LE | aplay - in a terminal in order to make tvtime to gather both audio and video from the device and route it to your master mixer, if this works you may wish to edit your tvtime launcher in order to add this command. Good luck! – Geppettvs D'Constanzo Dec 17 '13 at 22:33
  • @GeppettvsD'Constanzo Thanks for your suggestion. As explained above, I can hear sound and change the volume using alsamixer. The problem is that TVTime can not change the volume. This does not change when I run TVTime using your command. – Chris Dec 17 '13 at 22:51
  • 1
    Check this out: askubuntu.com/a/217462/9598 – Geppettvs D'Constanzo Dec 17 '13 at 23:07
  • @GeppettvsD'Constanzo Thanks, I also already tried that but it did not fix the problem. Instead, the output looks even more worrisome, it now complains about an "Invalid CTL". I have updated the question with the detailed output. – Chris Dec 17 '13 at 23:24
  • 1
    @GeppettvsD'Constanzo I just found the answer above the one that you linked and it did the trick for me. Thank you very much! – Chris Dec 17 '13 at 23:29
1

I found the answer to a very similar question: https://askubuntu.com/a/51574/14220

This worked for me. Here is what the relevant line in my tvtime.xml now looks like:

<option name="MixerDevice" value="hw:0/CD"/>

Note that this is case sensitive, using a lowercase "cd" as suggested by the tvtime.xml man page did not work!

2
  • for me it did not work.probably the sound wire is attached to somewhere else on motherboard. – Minimus Heximus Mar 24 '14 at 13:52
  • 1
    @MinimusHeximus First of all try to see whether you can hear sound when turning the CD volume up using alsamixer. If that does not work, this is not the right solution for you. – Chris Mar 24 '14 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.