5

So i'm trying to install Ubuntu on my laptop, it seems to work fine until it tries to install grub. I haven't seen progress the past hour and this is the second attempt.

I'm trying to install 13.10, using a Linux Live USB. I don't care about the contents of the laptop.

I've been trying to find instructions about installing grub before starting the installation, hoping that would solve my issues, but I came up empty.

Laptop is 2 years old, it used to run dual-boot windows 7 and Ubuntu. I'm now doing a fresh install of just Ubuntu.

I hope anyone knows how I can find out why it is happening.

  • Could you describe your partitions and error message if anyone is shown. – yilmi Dec 17 '13 at 20:52
  • I haven't seen any error message. I just rebooted to get you the partition info, currently it shows me 3 partitions: 510MB efi, 495GB ext4 and 4 GB Swap. at /dev/sda1 through 3. – Asteryz Dec 17 '13 at 21:03
7

During the installation, there's a way to skip installing grub. Look at the "Device for boot loader installation" dropdown.

Instead of choosing the entire device "/dev/sda", choose the partition you'll install Ubuntu, such as: "/dev/sda1"

Device for bootloader installation dropdown menu

If you choose "dev/sda", you're supposed to rewrite the boot record for the entire drive, which I believe is what's your issue is all about.

But when you choose "dev/sda1" (or sda2,sda3...) you get to place the boot flag at the beginning of the partition, not the entire drive. That does not make you go for a change in your bootloader. In other words, you place a boot flag as a "subtitle" to your pre-existing bootloader.

After you apply the fix, if you ever want to switch to Grub2 for any reason, use the Ubuntu Boot Repair disk: Ubuntu Boot Repair

If all else fails, try to "rewrite your MBR" because during your uninstallation of Windows, its boot sector may have accidentally remained there. Since you are doing a fresh install of Ubuntu, this may stand as the final option since there's a small chance that Ubuntu failed to handle your Windows partition's boot flags correctly.

| improve this answer | |
4

In case you have issue when installing on UEFI BIOS (not sure if this issue is adressed only to Acer Laptops) there is a topic here that helped me solve this issue.

I will copy the commands in case it disappears, but all credit goes to Pueseso from Acer Community forum.

-- Boot Ubuntu Live USB
-- open terminal
sudo -s
ubiquity -b
-- Press Continue testing after installation is over.

--Now we will return to the CLI (  https://wiki.debian.org/GrubEFIReinstall  )

sudo mount /dev/sda2 /mnt #sda2 is the root partition
sudo mkdir /mnt/boot/efi
sudo mount /dev/sda1 /mnt/boot/efi #sda1 is the efi partition
for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt$i; done

modprobe efivars # make sure this is loaded

-- notice the bootx64 file
efibootmgr --verbose

-- We will reinstall grub-install for a 64bit version
apt-get install --reinstall grub-efi-amd64

grub-install —no-nvram —root-directory=/mnt
chroot /mnt
update-grub
cd /boot/efi/EFI
cp -R ubuntu BOOT
cd BOOT
cp grubx64.efi bootx64.efi

-- You are finished, reboot the system.
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.