I have a clean install of 13.10 using the 3.12 kernel. When I shutdown or restart the process hangs. I press a key and I see:

**Killing all remaining processes .......      [fail]** (fail is in red)

This is followed by more info (sometime referring to nmdispatcher or modem and always ends:

mount:/ is busy

will now restart (or halt as the case may be)

Then nothing else happens the process hangs there, power on my PC (Dell 5150 desktop) remains on and I need to do a "hard reset" to turn my PC off.

I have seen relatively similar problems but none match mine exactly, I have attempted using:

sudo shutdown -P now


sudo shutdown -H now

But the results are the same.

I am concerned that this unclean shutdown may cause problems and I would like to know how to solve the problem. Can anybody help me? I am not too experienced with Ubuntu and I'm stuck... thanks

  • Please see the answer to this question on how to troubleshoot slow shutdowns. Then report back what is that misbehaving application which won't terminate. – falconer Dec 17 '13 at 18:30
  • Ok, followed the procedures and reading through the crash report I see pci_devices does not terminate at computer shutdown – welfare Dec 17 '13 at 20:22
  • That looks like hardware/kernel related. Have you tried this ? – falconer Dec 17 '13 at 21:31
  • Yes I tried the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force" part of that solution, I don't have an NVIDIA card so didn't follow the rest of it: no change. I even did some reading around and thought it might be a kernel issue so I only updated to the 3.12 kernel yesterday before posting but still made no difference. – welfare Dec 18 '13 at 16:40
  • @welfare GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force" and then sudo update-grub did not worked for me ! – Edward Torvalds Nov 11 '14 at 9:05

You probably have tried this one but, since you haven't mentioned that - try sudo reboot?

  • Thanks for the suggestion but, yes when I tried it I got the same result. – welfare Dec 17 '13 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.