1

I'm trying to install tmux, but getting this error. I'm also curious to how to resolve such issues as this comes up pretty often when installing these packages sometimes. When it says Depends on a specific package. does that mean its missing and you have to install it before you can install the wanted package (tmux in my case).

But if I wanted to install the missing dependency (linux-headers-3.2.0-53-virtual) I get an error too. -- sudo apt-get install linux-headers-3.2.0-53-virtual


sudo apt-get -f install tmux

Reading package lists... Done
Building dependency tree       
Reading state information... Done

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:
 linux-headers-virtual : Depends: linux-headers-3.2.0-53-virtual but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
1

Then try,

sudo aptitude install tmux
| improve this answer | |
  • i always thought apt-get and aptitude was the same command? whats the difference – Patoshi パトシ Dec 17 '13 at 17:59
  • thanks it seems to be working. so the issue i was having was because linxus-headers-virtual had to be removed before installing tmux? – Patoshi パトシ Dec 17 '13 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.