8

I am using transmission-daemon and controlling it through the webgui.

Currently I have two torrents from separate trackers that are on 0B of OB status. I am using transmission. On one torrent at last announce it says "got 50 peers" the other "got 48 peers."

port 51413 is listed as open

I have changed the ownership of the download folder to debian-transmission

Any ideas? I'm fresh out of troubleshooting steps.

  • How many seeds does it say you have? – Seth Dec 17 '13 at 3:49
  • @Seth 142 and 47 seeders – curios Dec 17 '13 at 3:50
9

In my case, it was also helpful to change the setting of the random port picking option to true. In transmission, you do it by following these instructions:

EditPreferencesNetwork Tab → Tick the first box

2

I switched to port 57558 and it now functions. I'm not sure if this is a long-term solution, but in any case shows that this is network issue and not something related to transmission. Thanks everyone for their help.

  • Perhaps my isp is blocking 51413? I understand that this is common port for torrenting? – curios Dec 17 '13 at 4:00
  • That is a very good possibility. Or perhaps you're in a NATed network where something else is using the external port, making you unreachable to the outside world? Many possibilities. – Jo-Erlend Schinstad Jun 1 '14 at 16:08
1

I've changed the setting peer-port-random-on-start from false to true. That did the trick for me(transmission-daemon).

  • how did you do that can you explain ? – rohith Jul 28 '16 at 14:13
  • $ sudo vim /etc/transmission-daemon/settings.json – user3751385 Jul 1 '18 at 7:46
  • Oddly, this worked. And I had opened up the port with iptables and tested with nmap – user3751385 Jul 1 '18 at 7:46
1

I was facing the same issue. Changed the peer-port-random-on-start to true as suggested. Still was unable to download. Checked on some of the other forums & found a tool called "deluge". Installed it on my Ubuntu 16.10 machine & the downloads are working fine now. Wonder what was the issue with transmission.

Below is the link to install deluge on Ubuntu 16.10 :

https://www.linuxbabe.com/bittorrent/deluge-bittorrent-client-ubuntu-16-04

  • 2
    Deluge is in the standard repositories with only a point release difference... – Fabby May 9 '17 at 22:34
0

I have AT&T at home and I was messing around with my router. I have always had the NetBIOS protocol turn off, but I had disabled the All Other Protocols option on my system. It appears that Transmission used one of the vague protocols with my router. As soon as I re-enabled it, I was able to get Transmission to work for me.

HTTP
HTTPS
FTP Telnet
SMTP
DNS
NetBIOS
POP3
IMAP
NNTP
IRC H323
All Other Protocols

0

I had the problem. The cause was the client being unauthorized.

To solve the issue, I changed the settings:

  1. Stop daemon: sudo service transmission-daemon stop
  2. Edit the settings: sudo vim /etc/transmission-daemon/settings.json (replace vim with your favourite text editor)
  3. Unrequire authentication: "rpc-authentication-required": false
  4. Whitelist localhost: "rpc-whitelist": "127.0.0.1"
  5. Restart daemon: sudo service transmission-daemon start

And now it works. If you suffered from this issue, it's possible that download-dir changed as well. so I suggest you check that option too and change it to your desire:

"download-dir": "/var/lib/transmission-daemon/Downloads"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.