0

I have an Asus G750. The touchpad (Elantech) works fine on Windows 8. However, after installing ubuntu the right mouse button is not recognized. The 'synaptiks touchpad management' software shows a cross sign under Touchpad Configuration->Hardware Information->Right Button. Similarly, from command line

shiva@shiva-G750JX:~$ xinput --list-props "ETPS/2 Elantech Touchpad" | grep Capabilities
    Synaptics Capabilities (302):   1, 0, 0, 1, 1, 1, 1

Which also, I believe, means 'right button not working'. Looking up all the help on this forum, I tried setting the "Soft Button Areas" parameter, but that did not change anything.

Can someone please help?

1

My answer comes from this blog post: http://www.evilcodingmonkey.com/2014/01/23/ubuntu-activate-multi-touch-on-elantech/

First. download this archive (from Ubuntu's bug reporting page): https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442/+attachment/3941591/+files/psmouse-elantech-x551c.tar.gz

Open a terminal, and follow these steps (after step 4, you will have no mouse at all):

cd ~/Downloads
sudo dkms ldtarball psmouse-elantech-x551c.tar.gz
sudo dkms install -m psmouse -v elantech-x551c</p>
sudo rmmod psmouse
sudo modprobe psmouse

Several users confirm their Elantech touchpad now has right-click and scrolling working. I hope it helps!

0

As stated in dpeebles' link, this is due to a faulty driver that simply assumes that there isn't any right mouse button for our touchpad. Just copy-paste the quick-fix solution from the link (which basically downloads and installs a patched driver) and you'll have a working driver, and thus a working mouse button.

It worked for me and for dpeebles on our G750's, so it ought to work for you as well.

-1

I can't help you, but this link describes the problem and solution. It works, I've had to do it for every flavor of Linux I've tried on this machine. "This machine" being my own Asus G750, of course. :)

https://superuser.com/questions/619582/right-elantech-touchpad-button-not-working-in-linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.