1

when I try to install VMWare Player on Ubuntu 12.04 LTS I get the following error:

Unable to build kernel module.

I saw in other similar questions that a suggested solution is to do the following:

cd /lib/modules/$(uname -r)/build/include/linux 
sudo ln -s ../generated/utsrelease.h 
sudo ln -s ../generated/autoconf.h 
sudo ln -s ../generated/uapi/linux/version.h

However, I don't have the last file, version.h although I have installed the linux headers but no luck.

I also tried to run

sudo vmware-modconfig --console --install-all

but it fails with the following message:

tmp/vmware-root/modules/vmmon-only/linux/driver.c:40:28: fatal error: linux/smp_lock.h:
No such file or directory
compilation terminated.
make[2]: *** [/tmp/vmware-root/modules/vmmon-only/linux/driver.o] Error 1
make[1]: *** [_module_/tmp/vmware-root/modules/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-44-generic'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/vmware-root/modules/vmmon-only'
Unable to install vmmon

Is there any other way to install the missing headers?

EDIT 1

The screen-shots bellow show what I see after I complete the installation

enter image description here

enter image description here

4

Your errors don't occur for me with VMware Player 6.0.1-1379776 X86-64 on Ubuntu 12.04 - Desktop X86-64. It would be helpful if you could mention whether you are running a 32bit or 64bit operating system, what version number of Vmware Player you are attempting to install, and whether you have done any kernel upgrades.

[The screenshots below require http to be added to the front, but I have too many links so I cannot type them like that, sorry.]

How To Graphically Install VMware Player 6.0.1-1379776 X86-64 on Ubuntu 12.04 - Desktop X86-64:

Step #1: Navigate to the directory you've saved VMware Player in.

img1

Step #2: Right click on the .bundle file and open the properties menu.

img2

Step #3: In the permissions tab check the box for "allow executing file as program".

img3

Step #4: Open terminal and type "sudo nautilus" as root privileges are needed.

img4

Step #5: Click "ok" on the error message regarding nautilus. img5

Step #6: Navigate to the directory you saved the .bundle file in, right click, and choose "open" from the menu.

img6

Step #7: Choose "run" as it will allow for graphical installation.

img7

Step #8: Accept the Vmware Player End User License Agreement and click "next".

img8

Step #9: Accept the VMware OVF Tool Component For Linux License Agreement and click "next".

img9

Step #10: Choose appropriate update option to your liking and click "next".

img10

Step #11: Choose appropriate statistics option to your liking and click "next".

img11

Step #12: If you have a plus key you can enter it now, if not don't worry about it, and click "next".

img12

Step #13: Click "install".

img13

Step #14: The installation will begin, please wait for it to finish.

img14

Step #15: Click "close".

img15

Step #16: Search for "vmware player" in your unity search area. Click on "Vmware player".

img16

Step #17: VMware player will open and be ready for use. [You may need to run vmware player as root to download the vmware tools.]

img17

  • thanks for your long replay! My ubuntu is 12.04 LTS i386, and I'm usin the VMWare Player 2.5.5. I'll try what you posted now. – Vasilis Dec 18 '13 at 23:25
  • I added two screen-shost to my question to see what I get after I complete the installation. I upvoted either way for your effort – Vasilis Dec 18 '13 at 23:40
  • Are the screenshots you added from a 2.5.5 installation attempt or a 6.0.1 installation attempt? Did you remove your previous vmware player installation before attempting a the new one? Do you desire 2.5.5 rather than a new version? – mango Dec 18 '13 at 23:46
  • I no longer have a 2.5.5 i386 installer, and vmware.com has disabled the download for that version. my.vmware.com/web/vmware/details/player_255_win/… – mango Dec 18 '13 at 23:56
1

How To Install VMware Player When Headers Need Building:

Step #1:

In terminal type: sudo apt-get install build-essential linux-headers-$(uname -r)

Step #2:

Right click on your .bundle file for vmwareplayer, check executable, and then double click to start the installation procedure.

  • Thanks for your reply. Unfortunately I have already done these steps but I still get the above errors. – Vasilis Dec 18 '13 at 8:42

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.