2

I looked at this and that then attempted to move /home to a (pre-existing) partition. Now I am unable to log into it.

I tried to use chown in recovery mode as per the psychocats tutorial, only to be told that /home/username doesn't exist. But when I run 'locate username', it's the first directory listed.

What did I miss?

  • paste the output of mount or findmnt. You should probably look into the answer here and review what you have done: askubuntu.com/questions/217397/… – Terry Wang Dec 16 '13 at 22:37
  • The partition wasn't mounting. I hadn't created a user directory, I had just dumped everything into /home – user222824 Dec 16 '13 at 23:21
  • locate consults a database that is only rebuilt once in a while, so it can be out of date. – psusi Dec 16 '13 at 23:35
1

First run ubuntu on normal mode, after press ctrl + alt + f1 and then login with your user name and password, now write sudo chmod 777 -R /home/Your_user_folder

If not posible, put the terminal answer here.

  • If chown does not work, I doubt that this will... – Wilf Dec 16 '13 at 22:53
  • 1
    I hadn't created the user_folder, I had just copied everything to /home. mkdir and mv have sorted everything, thank you. Well, almost everything, I still have to figure out how to get my configs for Cinnamon and Firefox back – user222824 Dec 16 '13 at 23:25
1

I suspect that the fstab file system table is still pointing at your old home partition or directory. Can you print or output the contents of /etc/fstab

You will likely need to change the entry for mounting /home

  • Thanks. fstab was okay, I just needed the user directory in /home. – user222824 Dec 17 '13 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.