I've just upgraded to Ubuntu 11.04 and I figured I'd give their new default music player a go. I have my music in the $home/Music folder and I was using Rhythmbox. The Banshee player has a handy item on import suggesting it can pull from Rhythmbox too. When I do it however it comes up with errors for all bar a couple of albums I bought recently via Amazon (mp3).

Any idea what I'm doing wrong? There are errors reported for all the tracks that didn't get pulled in, suggesting it read the file list correctly. I also tried importing by directory with the same results.

The error reported for each track is 'Unable to import song'.

I initially thought perhaps it was a codec issue because I'd just upgraded and presumably the codecs I'd need were no longer on the sources list. I found those and installed them and found all the other ways of playing can deal with the music there.

I then connected to my daapd server and was able to play the music on Banshee from there. This is actually the same music so I'm now guessing it's not a codec issue.

  • I'm having the same problem so I figure I'll stick with Rhythmbox for now – Alex Weber May 2 '11 at 11:13
  • I think I've just figured out the issue. It appears all my music files in the directory have no filename extension. If I rename them to add a .mp3 they suddenly start to work. I'm just figuring out the best way to add the extension everywhere now. – Colin Newell May 2 '11 at 11:49

Banshee currently uses a file extension whitelist to determine which files it can import. This is much faster because Banshee only has to look at the filename, rather than open each file and read the mime type information. It's been generally agreed that files without an extension should probably be checked to see if they can be imported. There's a bug report open for this issue, but unfortunately it wasn't fixed in time for Natty.

In your case I'd recommend writing a script to add a filename to the end of all of your files (as I understand it, it wouldn't even have to be accurate -- just something Banshee would accept, such as .mp3), or you'll need to wait until Banshee can open files without an extension. Hopefully this will happen by Banshee's 2.2 release in September.


Can only provide suggestions. Is you music English? If no, it may be tag encoding issue. I run into this every time I deal with Russian music. May be non-English characters in file path? Even UTF-8 apps can suffer from this. Anyway, install EasyTag or similar and try simply re-saving tags on the files. Update tags version to newest, ensure UTF-8 encoding.

  • No, it's regular english I'm afraid. I'll take a look at the tags to see if that makes a difference. – Colin Newell May 2 '11 at 11:19
  • Thanks, that suggestion helped me figure out what the problem was. None of the files had filename extensions which mean the easytags didn't see the files. It looks like banshee didn't like that either. – Colin Newell May 2 '11 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.