1

My keyboard layout in Ubuntu doesn't fully correspond to my actual keyboard. This could be either because I chose the wrong option during the installation, or because my misguided attempts to fix the keyboard layout switcher that Ubuntu broke in 13.10, compared to 13.04.

Here's what I see in Ubuntu keyboard layout chart:

enter image description here

On my keyboard there are Backspace instead of ], ) above 0 and [ instead of :. It says "English (US)", but doesn't look like one. Also, the keyboard in the chart has an L-shaped Enter key, so can't be "English (US)", but probably some European type. How do I change my keyboard layout to a proper one? Command line is ok.

I am using English (US) and Russian layouts, between which I am switching with Ctrl+Shift. I managed to fix that bit, so that both Ctrl+Shift and the shortcuts that contain it (like Ctrl+Shift+Tab to switch browser tabs backwards,) do work.

I am using Ubuntu 13.10 32-bit.

  • I just upgraded from 13.04 to 13.10 and am having the exact same issue. I also did not try to change with the layout switcher. I just ran the upgrade and then my layout is now identical to the one you have above. – sruffell Jan 29 '14 at 18:29
  • For posterity, while I am still unsure how the update resulted in this change, I eventually was able to fix it by using gnome-tweak-tool, selecting Typing -> "Japanese keyboard options" and setting it to disabled. – sruffell Jan 30 '14 at 23:27
1

The screenshot you've shown has numerous mistakes that don't match an actual layout, including an extra Escape key, misplaced Backspace, etc. Either you have loaded a custom layout unknowingly, or something is very wrong with your default English (US) layout. I recommend filing a bug report with Ubuntu, because what you are seeing should not be possible without very explicit (and misguided) customization.

PS: The L-shaped enter key is not important. Keyboard layouts only care very slightly about the shape and width of specific keys.

  • Ok, so it were really my misguided attempts to fix the keyboard layout switcher that are to blame. Thanks for helping to figure this out! I have reinstalled Ubuntu, applied just this one solution, and everything works without such weird bugs. – Nickolai Leschov Dec 27 '13 at 13:43
  • It works faithfully to its description, though: it does "provide some relief", namely I am now again allowed to use "Ctl+Shift" for switching layout together with shortcuts that contain it, like "Ctrl+Shift+Tab" for switching tabs backwards in the browser or "Ctrl+Shift+Back" for selecting words backwards in the editor, but now it comes at a cost of keyboard glitches and freezes. Why, oh why did Ubuntu have to break keyboard? I wonder if I can comprehensively fix it. Do you think it merits asking a separate question? Should I edit/add comments to my original one? – Nickolai Leschov Dec 27 '13 at 13:48
  • Your answer helped, but I don't know if one can count this as a solution. – Nickolai Leschov Dec 27 '13 at 13:50
0

This is posted in a comment above, but given that I had the very same layout issue:

It was fixed by installing gnome-tweak-tool and disabling the "Japanese keyboard options" under typing.

Running:

$ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+us+inet(evdev)+jp(nicola_f_bs)" };
xkb_geometry { include "pc(pc105)" };
};

I could see that there were some japanese options set, but I couldn't find what file to disable them in. I eventually ran across this answer: https://askubuntu.com/a/386469/18518, which prompted me to check what options were available in the tweak tool.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.