6

I have purchased a piece of software to configure programable radio control transmitters. It says it will run on Linux, see below:

Digital Radio runs on: Microsoft Windows 2000/2003/XP Microsoft Windows Vista/Seven/2008, Linux Ubuntu or a distribution with Mono, 32 or 64 bit, also in a virtual machine.

Linux requires the Mono package installed, with also the Visual Basic 2005 runtime library. The Linux version is the same executable file of the Windows platform, and can be execute using Mono. You don't need Wine. All the tests have been done on Ubuntu Desktop 10.10

I have tried for weeks to get the drivers for the cable to work in XP or Win7 and I admit defeat.
It looks like Ubuntu can run the cable effortlessly but now I can't get the software going.

Tried to run in Ubuntu 10.04 with mono, GUI failed and I got the following message in terminal.

$ mono ~/Desktop/GigRadioLinux/DigitalRadio/DigitalRadio.exe
The entry point method could not be loaded

Windows installation requires using a 30 odd character Passkey and a 4.24k text file as a "license" to be entered during running of the exe file.

Can someone tell me how I enter the passkey and license into terminal, or is that not my primary problem? I don't understand "entry point method". Tried Wine and that didn't work either.

The developer responded to my earlier emails re the cable drivers, but hasn't replied to questions regarding this.

If I have left out anything important let me know and I will try to supply more information.

  • Have you tried asking the suppliers/producers? – user4815 Dec 16 '13 at 10:57
  • Did you install Mono System.Windows.Forms library (for CLI 2.0/4.0)? – user273400 Apr 24 '14 at 2:29
6

I assume you're talking about this application. I downloaded it, unzipped it and went into the directory and then:

sudo apt-get install mono-vbnc
mono DigitalRadio.exe

I did get the same error as you before installing the VB runtime. But afterwards, it loads just fine. No idea if it works because I don't have a USB transmitter.

I also have no idea about registration. No prompt asked me for details. Clicking buy just loads a browser window. Ask the developer.

Oh and before I forget, don't use 10.04 for desktop. Certainly don't use 10.10 for desktop. They're both long out of support. I tested this (again, the application, not the driver) on the latest version of Ubuntu (13.10) and Mono 2.10. At the very least I'd suggest Ubuntu 12.04 which is supported until 2017.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.