5

I am running Openbox without any DE. And I also use some Qt apps such as VLC, Virtualbox and Skype. However, they require some gconf / dconf settings to be set.

For instance to set the correct icon theme:

$ gconftool-2 --set --type string /desktop/gnome/interface/icon_theme Faenza

When running Gnome, these settings are loaded and used by the Qt apps. However, when running native Openbox, these settings are ignored and I presume that this is due to some gconf / dconf services not being loaded when running Openbox without Gnome.

Therefore my question, how can I run gconf / dconf without Gnome to have my Qt apps having access to the relevant gconf / dconf settings?

  • +1. Have been experiencing the same issue with some Qt apps on LXDE (e.g. Clementine) – Glutanimate Dec 16 '13 at 8:37
  • Good to know that I am not the only one. In my case it is a crucial issue because the Qt apps behave very unresponsively and show terrible lags in the GUI. This behaviour is not apparent in Gnome. What was your resulting issue and were you able to resolve it? – Dan Sherban Dec 16 '13 at 8:48
  • Nothing major, fortunately. Just some cosmetic issues (apps using the wrong iconset). I can't say I've experienced any particular lag with those applications. As far s the troubleshooting is concerned I followed pretty much the same steps as you did: Set some dconf/gconf values and tried to find any other possible way to change the theme settings for specific applications. – Glutanimate Dec 17 '13 at 6:16
  • One possible reason why I am not facing the same issues as you are might be because I am running some GNOME components on startup. Specifically, these are the lines my autostart file includes: nautilus --no-default-window, /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 and gnome-keyring-daemon --start --components=pkcs11. As far as I remember I had set these up to get Nautilus and other GNOME apps to work properly. Maybe you could try some of them out on your system and see what happens? – Glutanimate Dec 17 '13 at 6:21
  • I added this to my .xinitrc but it did not change anything. I still believe I have to start gconf in some ways. Any ideas how? My xinitrc: pastebin.com/0eic6m5t – Dan Sherban Dec 17 '13 at 23:33
2

I am not entirely sure if this is all but I have compared my Gnome environment with Openbox and found the following additional processes to be started by Gnome:

gsettings-data-convert &
/usr/lib/Gconf/gconfd-2 &
/usr/lib/dconf/dconf-service &

In addition it might help to export the following variables:

export DE=gnome
export DESKTOP_SESSION=gnome

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.