I have installed PyCharm on my brand new Ubuntu 13.10 laptop.

To launch PyCharm, I find I must navigate to the directory that pycharm lives in, and execute it from there as such:

cd home/matt/software/pycharm/bin sh pycharm.sh

I hope this isn't asking too much, but I would like to be able to click on an icon in the Launcher to launch this application.

I tried right-clicking on the PyCharm icon in the Launcher when the app is running and selecting "Lock To Launcher" but this doesn't work (after pinning, when I try to run the software this way, the icon throbs in a very awkward manner a few times and does nothing).

A small app called Alacart was rumoured to be useful, but I have no idea how it works, and it appears useless. I'm not sure why the authors teased us with a "Help" button if there are no help files written for us to view.

Further attempt has included reading page after page of technical documentation on how to write scripts that will somehow help me customize my experience.

How can I set up PyCharm to launch from the Launcher???

  • 1
    "Lock to launcher" button works on UBUNTU LTS 16.04, PyCharm 2018.2
    – techkuz
    Aug 28 '18 at 7:13
  • On Ubuntu 18.0x: i. launch pycharm, ii. right click pycharm icon on the launcher, , iii. in the dropdown list, select "Add to Favourites".
    – Zhubarb
    Dec 29 '18 at 10:04

PyCharm can create it's own launcher icon (but it's not created by default).

All you have to do is:

  1. Start PyCharm.
  2. From the Tools menu, select "Create Desktop Entry..."
  3. Tick the corresponding box if you want the launcher for all users.
  4. If you selected "Create entry for all users", you will be asked for your password.
  5. A green message bubble should appear informing you that it was successful.
  6. You should then be able to find PyCharm in the Unity Dash or pin it to the launcher.

Note: You may need a system restart before it appears.

  • Thanks for you answer! I did what you recommended, but alas, when I click on the icon I now have pinned to the Launcher, it just throbs in a very awkward manner a few times and does nothing. Very confusing.. Dec 16 '13 at 8:12
  • 3
    @MattO'Brien Can you find a PyCharm file in ~/.local/share/applications (for your user) or /usr/share/applications (for all users). Right click this > Properties, and check the 'Command' field.
    – kiri
    Dec 16 '13 at 8:15
  • 6
    I am using PyCharm CE, and there is no "Create Desktop Entry..." in the Tools menu.
    – mhaghighat
    Feb 28 '18 at 20:30
  • 1
    @mhaghighat Open PyCharm go to Help| Find action| Type "Create Desktop entry"
    – Ash
    Sep 14 '18 at 22:15
  • 2
    @Ash: manually grepping for "Create Desktop entry" no longer yields joy. Recent versions of PyCharm appear to have completely removed this useful functionality. mightypile's general-purpose solution is everyone's best bet, now. Feb 7 '19 at 22:12

The "purest" method, in my opinion, is to simply create a launcher in a text editor that looks about like this:

[Desktop Entry]
Exec="/opt/pycharm-2017.1.1/bin/pycharm.sh" %f
Comment=The Drive to Develop

I believe this one was created by JetBrains, but you can type your own. Then save it to /home/yourname/.local/share/applications/appname.desktop for a launcher tied to your own login, or to /usr/share/applications/appname.desktop if you want it to apply to other users of your system.

Obviously, once editing, you can modify the icon, etc. And you can transfer this skill to other apps or tasks.

  • As of today (May 24, 2021) in Ubuntu 16.04.7 LTS (now on ESM) the path: /opt/pycharm-2017.1.1/bin/ no longer exists and is replaced by /snap/pycharm-community/current/bin/. Note that current is symbolic link to 238 which is probably the build number which changes on pycharm updates. Don't forget to chmod a+x appname.desktop. May 24 at 12:34

I had the same problem after "Create Desktop Entry...". This is what solved my problem: Go to the bin folder of the PyCharm and add following line to the beginning of pycharm.sh script:

export JDK_HOME='your java home folder'

and save the file. Now, run the launcher entry from Unity.

  • This fixed my problem, finally! Been looking for a solution for this one for a while. Thanks! Feb 18 '16 at 23:44
  • @diplosaurus you are very welcome! Feb 22 '16 at 8:46

There is a program called "main menu" available from the software centre. It allows you to make launchers for any command.

Also you need to run the cd and the launch as one command like this:

sh -c "cd /folder/to/go/to  && launch-command -options"

Click new item Click new item

Enter a name for the launcher and the command, and maybe a picture Enter a name for the launcher and the command, and maybe a picture

  • If you read the original version if this it may not work because of the lack of the single command using sh. Check edited version above. Dec 16 '13 at 7:20
  • please forgive me. Once I create this New Item, what is the next step? My Launcher is just sitting there in the "Main Menu" app. How do I make this useful? Dec 16 '13 at 7:58
  • Ahh, here we get confused because I use Gnome not Unity. It should now appear in the Unity Dash. I assumed you could drag it from there to the unity launcher bar thingy like I can in Gnome. Dec 16 '13 at 8:05
  • Look in the folder: ~/.local/share/applications can you see the launcher? Open dconf editor (install if you don't have it) and go to: "desktop-> unity-> launcher -> favorites" Try adding the name of the launcher into that list. Dec 16 '13 at 8:13
  • Under "desktop-> unity" we only have "lenses" and "runner." Dec 16 '13 at 8:23

Assuming default Gnome WM, with the PyCharm Application open, right click on the dock icon. Choose "Add to Favorites" option.

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.