0

Suddenly I can't find the bluetooth icon on the LXDE system tray. I might have disabled it by mistake. How do I get it back?

I tried to open "run" from the menu and typing bluetooth-agent but nothing happens.

I used to disable bluetooth by right-clicking the icon and choosing "disable" (or something like that) just to save battery charge. It used to reappear on restart but now it doesn't. It's there in unity but not in LXDE.

lsmod | grep bluetooth gives out this bluetooth 202226 22 bnep,btusb,rfcomm

edit: following this question Can't enable Bluetooth 13.10 I tried try sudo rfkill unblock bluetooth but it did nothing

1

Lubuntu, which has LXDE as its desktop environment, uses blueman-manager. Here's something on how to disable it:

Disable Bluetooth

This is achieved by blacklisting the relevant bluetooth modules. To find these, issue the following in LXterminal:

lsmod | grep bluetooth

An example out would be:

bluetooth 179900 23 rfcomm,bnep,btusb

Using the above example, you would edit the blacklist.conf file, again using LXterminal:

gksudo leafpad /etc/modprobe.d/blacklist.conf

and add the following lines to the end of the file:

blacklist rfcomm blacklist bnep blacklist btusb blacklist bluetooth

After rebooting, issuing:

lsmod | grep bluetooth

Should not find anything.

Sources: here and here.

| improve this answer | |
  • well thank you but I need to enable it not disable it – Mina Michael Feb 12 '14 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.