1

All window decoration is black. However scroll bars, maximize, minimize and exit buttons are active if one can find them.

Separately, in the case of gnome-terminal, all text, whether prompts, std output or input is invisible. Text input is active. I can launch and kill applications in the window and kill the window by typing exit.

I have tried reinstalling compiz, compiz-core, compiz-gnome and xserver-xorg with no change in behavior.

I have also tried several other incantations found on the web with no change in behavior.

If I ssh -Y into the machine from a different machine the windows are properly decorated and gnome-terminal text is visible.

What log files might be relevant? Any ideas how to fix?

1
  • Have you tried to change the settings in Edit> Profile Preferences in Terminal ? – user224082 Dec 18 '13 at 13:01
0

EDIT: After fiddling around a lot, I found the solution!

Install Mir as suggested at https://askubuntu.com/a/363488/230195!

=== Original Post ===

I've got the same problem since today though I have absolutely no idea what could've broken my system like that.

Changing the Profile Preferences doesn't seem to change anything, the window still isn't visible. Moreover it seems like it's not only a problem in gnome-terminal... when launching byobu the window will also stay transparent.

I also noticed that when logging into Unity instead of Gnome on my system, the notifications (e.g. WiFi connect) are entirely black, as well as terminals spawned via Ctrl + Alt + T. The application launcher and indicator bar are also not present.

Not the answer you're looking for? Browse other questions tagged or ask your own question.