10

Super key + D shortcut doesn't work in show desktop functionality for me in Unity. I have searched and found solutions for adding a button in Unity launcher but I don't want that. I just want the keyboard shortcut to work for speed.

I found that Ctrl + Alt + D do something similar but gedit window doesn't bother to care for it.

3
  • That is odd, the keyboard shortcut works on my machine. I upgraded from 10.10. You should be able to find the appropriate action in keyboard shortcuts in the Control Center (my laptop is packed away atm, can't check). May 2, 2011 at 9:37
  • I did a fresh install, and it doesn't work, other shortcuts work though
    – Ashfame
    May 2, 2011 at 9:59
  • 1
    My Super-D gone too, hmm.. It was working yesterday. Updates?
    – Extender
    May 2, 2011 at 14:12

7 Answers 7

15

There already is a keyboard shortcut that lets you see the desktop. It is just mapped to Ctrl + Alt + D. If you wish, you can remap it to Meta + D.

Search for Keyboard settings. Open Shortcuts tab. Move to Navigation. Scroll down until you see the option Hide all normal windows. Double click on it and press Meta + D. Now, Meta + D will show you the desktop from now on.

enter image description here

0
7

Just got to settings ---> appearance ---> behavior ---> add show desktop to the launcher

then try the keyboard shortcut again

2
  • woah!! is it documented anywhere?. Mar 6, 2017 at 21:35
  • this worked. Wonder if it will keep working.
    – bluppfisk
    May 30, 2017 at 7:22
5

I went to Power Button > System Settings (Control Panel) > Keyboard Shortcuts and changed the shortcut key for the action "minimize all windows and set focus to desktop" to Super + D from Ctrl + Alt + D and now gedit obeys it too.

Its weird but its a bug that I certainly have no idea to reproduce. Another weird thing is I had to change it to Super + D & for some it works by default but since it seems to work fine now, I shall be marking this as the answer.

1
  • Some strange effect after that - Super-D mostly working, but first time Dash is displayed, it's a bug
    – Extender
    May 2, 2011 at 14:22
1

For those without an "Appearance" option in their settings, try this. This is an easy way to show desktop in Ubuntu 18.04 L.T.S. without installing any third-party apps. It may work for other releases as well. Go to Settings->Devices->Keyboard then scroll to "Navigation Section." Click "Hide all normal windows" which is probably set to "disabled." Enter your new keyboard shortcut, which I set to CTRL+Alt+D. Voila! Instant desktop!

1
  • Hi! Welcome to AskUbuntu! The question is about the Unity desktop environment, however this answer applies only to Gnome. Sep 4, 2019 at 13:48
0

go to Preferences -> Keyboard Shortcuts ->

  1. Window Management
  2. Sound
  3. Desktop -> Here you can add a new shortcut for that
  4. Accessibility
3
  • I will have to add a custom shortcut for it? Was it removed in Unity? And your instructions are for gnome, in Unity, we go to Power Button > System Settings (Control Panel) > Keyboard settings. And even if I am adding a custom shortcut, how would I associate it with the action?
    – Ashfame
    May 2, 2011 at 7:31
  • You need keyboard shortcuts and on mine its mode4+D to show desktop
    – robin0800
    May 2, 2011 at 7:40
  • ah yes I meant Keyboard shortcuts only
    – Ashfame
    May 2, 2011 at 9:58
0

You have somehow saved another keybinding for that action. To go back to the default keybindings run this:

gconftool --recursive-unset /apps/gnome_settings_daemon/keybindings
gconftool --recursive-unset /apps/metacity/global_keybindings
gconftool --recursive-unset /apps/metacity/window_keybindings
0

On Ubuntu 20.04 i use Ctrl + Super + D

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.