34

I am using thunderbird as my email client and i use a signature to all my outgoing mails. How ever i can see the -- (double dash) which prepends to my signature. Is it possible to avoid the double dash -- ?

8
  • 11
    You shouldn't avoid it, as it's an Internet standard designed to enable email programs to recognise signatures and deal with them appropriately.
    – Mike Scott
    May 2 '11 at 7:21
  • 2
    Lol i know that, i just want to avoid that double dash.
    – karthick87
    May 2 '11 at 7:43
  • 1
    Who cares that it's an internet standard. It's annoying. I'm getting rid of it. Thanks, +1 for the q n a Jan 2 '13 at 10:25
  • There are standards on the internet now?
    – Nomic
    Jun 17 '14 at 11:52
  • 4
    It is not an Internet Standard though. The relevant text in RFC 3676 in particular makes no such requirement. What it does is to note a "long-standing convention" and enable the continued use of that convention by defining certain rules for a document of MIME type "text/plain;Format=Flowed". In fact Thunderbird does not even produce documents of that type.
    – ajm475du
    Sep 12 '14 at 15:51
61

Open the Config Editor: Either Tools -> Options or Edit -> Preferences

Go to Advanced -> General -> Config Editor

Then search for mail.identity.default.suppress_signature_separator and set it to TRUE by double-clicking it.

Now all new emails are created without the -- before the signature.

6
  • I dont find that entry in thunderbird config editor.
    – karthick87
    Sep 14 '11 at 11:50
  • FYI, this worked for me perfectly on the latest version (12.0.1)
    – Jaxidian
    May 21 '12 at 13:44
  • Works on Thunderbird 24.1.1 Dec 4 '13 at 10:54
  • 1
    It works ! BTW, is it possible to remove also empty blank lines before the signature ? Dec 8 '14 at 11:44
  • 2
    Note that if there are multiple identities there will be separate setting for each e.g. mail.identity.id1.suppress_signature_separator, mail.identity.id2.suppress_signature_separator etc.
    – Greendrake
    Sep 21 '15 at 2:06
4

I researched this recently and found that they will provide a checkbox in either v3.2 or v3.3 to allow users to elect not to show those dashes. Wait.

1
  • I tried this but it doesn't really work. The separator will still be inserted when I create a new mail. Even a restart of TB didn't help. Does anybody know why this doesn't work?
    – user33533
    Nov 12 '11 at 11:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.