6

We want to migrate from Windows to Ubuntu linux. In the past we used Evolution client to our mail server (Novell GroupWise 2012). This mail servers uses SOAP protocol. In the past there was an option to use SOAP (GroupWise) in Evolution. This seems to be removed.

After some googling I came accross this : Is Groupwise not supported in Evolution? This thread had a solution to patch the latest Evolution with SOAP (GroupWise). I tried this on my Ubuntu 13.10 but errors occur. This solution was made for Ubuntu 11.

These are the steps:

1. Install git (sudo apt-get install git)
2. git clone git://git.gnome.org/evolution-groupwise
3. cd evolution-groupwise
4. git checkout -b 3.2.0-patch EVOLUTION_GROUPWISE_3_2_0
5. git cherry-pick 3aae80f55d5fd565274f19210564e74d5350a66c # This is the patch for the SOAP port bug
6. Open configure.ac, at about line 48 add the line AC_CHECK_LIB(gthread-2.0, g_thread_init)
7. sudo apt-get build-dep evolution
8. ./autogen.sh
9. make            
10. sudo make install
11. Edit /etc/services like bruhein describes

On step 8 an error occured.

configure: error: Package requirements (libedataserverui-3.0 >= 3.2.0) were not met:

No package 'libedataserverui-3.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBEDATASERVERUI_CFLAGS
and LIBEDATASERVERUI_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Then I tried to install the missing dependency without success.

root@ubuntu:~/evolution-groupwise# apt-get install libedataserverui-3.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libedataserverui-3.0-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  evolution-data-server-doc

E: Package 'libedataserverui-3.0-dev' has no installation candidate

Can somebody help me with this?

Thanks in advance.

Kr,

Joeri

Small update: In the next release their will be native Mac support, which means it will probably work for imap clients like evolution: https://www.novell.com/communities/coolsolutions/groupwise-blog-native-mac-integration-groupwise-cornell/

3
+25

Ubuntu 13.10 has reached its End of Life (EOL) and is no longer supported.

The repositories for older releases that are not supported get moved to an archive server and are available at old-releases.ubuntu.com instead of archive.ubuntu.com, which is why you are unable to install packages.

Kindly refer to this page for steps to install software on an unsupported release.

However, I would advise you to install a supported release like 14.04 or 14.10 instead. It is preferable to go for Ubuntu 14.04 since it is an LTS (Long Term Support) release and is supported till 2019.

| improve this answer | |
0

You can try to download and install manually the package file. Choose the file to match your system type:

... and them install it manually with 'dpkg -i libedataserverui-3.0-dev_3.2.3-0ubuntu7.2_XXXX.deb' , where XXXX is the system architecture.

| improve this answer | |
  • On a side note, I get the following error when I run $ sudo apt-get install libedataserverui-3.0-1: The following packages have unmet dependencies: libedataserverui-3.0-1 : Depends: libebook-1.2-12 (>= 3.2.3) but it is not going to be installed Depends: libecal-1.2-10 (>= 3.2.3) but it is not going to be installed E: Unable to correct problems, you have held broken packages. – Raffi Khatchadourian Dec 19 '14 at 21:46
  • And when I try yours: libedataserverui-3.0-dev depends on libedataserverui-3.0-1 (= 3.2.3-0ubuntu7.2). libedataserverui-3.0-dev depends on libgtk-3-dev. libedataserverui-3.0-dev depends on libedataserver1.2-dev (= 3.2.3-0ubuntu7.2). libedataserverui-3.0-dev depends on libebook1.2-dev (= 3.2.3-0ubuntu7.2). evolution-data-server-dev (3.10.4-0ubuntu1.5) breaks libedataserverui-3.0-dev and is installed. evolution-data-server-doc (3.10.4-0ubuntu1.5) breaks libedataserverui-3.0-dev (<< 3.4.2) and is installed. Version of libedataserverui-3.0-dev to be configured is 3.2.3-0ubuntu7.2. – Raffi Khatchadourian Dec 19 '14 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.