10

I am using ubuntu 13.10 64bit. I got one sided (one channel) sound only in headphone. Laptop speaker is quite good. Headphone jack of laptop and headphone are both working well. It's software issue. I regularly upgrade system and this problem is happening after last 1 or 2 upgrade.

Also there is a workaround. Set the volume level to low and set it high quickly. After doing this couple of times restore my headphone's both channel. How to solve this permanently?

uname -r

3.11.0-15-generic

aplay -l

 **** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC270 Analog [ALC270 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

cat /proc/asound/version

Advanced Linux Sound Architecture Driver Version k3.11.0-15-generic.

head -n 1 /proc/asound/card*/codec#*

==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC270

==> /proc/asound/card0/codec#3 <==
Codec: Intel PantherPoint HDMI

pulseaudio --check [shows no output. with sudo return permission denied to read home directory]

pulseaudio --dump-conf

### Read from configuration file: /etc/pulse/daemon.conf ###
daemonize = no
fail = yes
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
allow-module-loading = yes
allow-exit = yes
use-pid-file = yes
system-instance = no
local-server-type = user
cpu-limit = no
enable-shm = yes
flat-volumes = no
lock-memory = no
exit-idle-time = 20
scache-idle-time = 20
dl-search-path = /usr/lib/pulse-4.0/modules
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = auto
log-level = notice
resample-method = speex-float-1
enable-remixing = yes
enable-lfe-remixing = no
default-sample-format = s16le
default-sample-rate = 44100
alternate-sample-rate = 48000
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 8
default-fragment-size-msec = 10
enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 1
deferred-volume-extra-delay-usec = 0
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 1000000

amixer -c 0

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 67 [77%] [-15.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [36.00dB]
  Front Right: 3 [100%] [36.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 18 [58%] [10.50dB] [on]
  Front Right: Capture 18 [58%] [10.50dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 [50%] [0.00dB]
  Front Right: Capture 60 [50%] [0.00dB]

pacmd dump-volumes

No PulseAudio daemon running, or not running as session daemon.

sudo pactl info

Server String: unix:/run/user/1000/pulse/native
Library Protocol Version: 28
Server Protocol Version: 28
Is Local: yes
Client Index: 28
Tile Size: 65472
User Name: shantanu
Host Name: shantanu-voillo
Server Name: pulseaudio
Server Version: 4.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1b.0.analog-stereo
Default Source: alsa_input.pci-0000_00_1b.0.analog-stereo
Cookie: 381c:e256
  • 2
    The output of pulseaudio --check, pulseaudio --dump-conf, amixer -c 0, pacmd dump-volumes and pactl info. – Braiam Dec 17 '13 at 17:58
  • @Braiam I have edited the question with your required information. – shantanu Dec 17 '13 at 18:10
  • Did you also check the headphones on a different device? – Svetlana Belkin Dec 23 '13 at 21:40
  • @belkinsa Yes. I also checked with multiple headphone. – shantanu Dec 24 '13 at 5:40
  • Your workaround (Set the volume level to low and set it high quickly. After doing this couple of times restore my headphone's both channel. ) works for me. How on earth did you work that out. any why does it fix it? – Chris Walsh Sep 27 '17 at 1:19
5

Try the settings in alsamixer - Open terminal and type alsamixer: enter image description here

You can use q and w to adjust the left and right channels.

  • It's not working. Volume changes in one channel. – shantanu Dec 17 '13 at 18:15
  • Sounds like either a bug or a hardware issue - sorry... – Wilf Dec 17 '13 at 18:18
2
+25

If you've already checked the connections, and they're good, and you're sure that it's the update that caused the problem, these links could help:

  1. No Sound When Headphones are Plugged in.

  2. You could update the system again or try purging and then installing alsa-utils.

  3. You could switch to booting with your previous kernel version.

0

start from the top. run the speaker test application to figure out what is going on.

if you can hear sound from both the laptop speakers, move on to inserting the jack in the headphones plug.

If you get sound from both speakers but from one headphone then the problem is in the connectors (since you stated you checked the headphones in another device already).

If that is the case perhaps acutally applying some pressure on the inserted jack may help.

  • I triple check my headphone and connector. All are okay. Build it speaker is working. – shantanu Dec 21 '13 at 14:41
  • Did you also check the headphones on a different device? – Svetlana Belkin Dec 23 '13 at 21:32
0

At first, none of my audio was working. Then I followed the instructions here to get my speakers working: https://help.ubuntu.com/community/SoundTroubleshooting

Still, I had no headphone sounds. I then followed the instructions here:

http://h30434.www3.hp.com/t5/Notebook-Audio/HP-Spectre-x360-with-Ubuntu-Plugging-in-Headphones-doesn-t/td-p/5543183

Then only my right ear was working.

What finally fixed it was to open alsamixer and change loopback to disabled. Suddently I got audio in both ears.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.