-1

First I used the compound command given here but it gave some errors so I executed each command separately that I may be able to figure out the where is the error. Adding repository and updating was fine but:

asim@ubuntu:~$ sudo apt-get install ubuntu-sdk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntu-sdk : Depends: qtcreator-plugin-ubuntu-cordova but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
asim@ubuntu:~$ 

I decided to install qtcreator-plugin-ubuntu-cordova separately then:

asim@ubuntu:~$ sudo apt-get install qtcreator-plugin-ubuntu-cordova
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qtcreator-plugin-ubuntu-cordova : Depends: qtcreator-plugin-ubuntu (= 2.8.1bzr56precise0) but 2.8.1bzr57precise0 is to be installed
E: Unable to correct problems, you have held broken packages.
asim@ubuntu:~$ 

Here I thought forcing the right version of the package would work fine but again:

asim@ubuntu:~$ sudo apt-get install qtcreator-plugin-ubuntu-cordova =2.8.1bzr57precise0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package 
asim@ubuntu:~$ 

Can somebody help me? I've been doing web development in php but I've just decided give a try to software development on Ubuntu.

Edit

apt-cache policy qtcreator-plugin-ubuntu-cordova qtcreator-plugin-ubuntu ubuntu-sdk gives:

root@ubuntu:/home/asim# apt-cache policy qtcreator-plugin-ubuntu-cordova qtcreator-plugin-ubuntu ubuntu-sdk
qtcreator-plugin-ubuntu-cordova:
  Installed: (none)
  Candidate: 2.8.1bzr56precise0
  Version table:
     2.8.1bzr56precise0 0
        500 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu/ precise/main amd64 Packages
qtcreator-plugin-ubuntu:
  Installed: 2.8.1bzr57precise0
  Candidate: 2.8.1bzr57precise0
  Version table:
 *** 2.8.1bzr57precise0 0
        500 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
ubuntu-sdk:
  Installed: (none)
  Candidate: 1.009~sdkppa~precise1~test6
  Version table:
     1.009~sdkppa~precise1~test6 0
        500 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu/ precise/main amd64 Packages
  • the error message told you what was wrong. you pinned a package and it broke stuff. – RobotHumans Dec 15 '13 at 3:40
  • What is the output of apt-cache policy qtcreator-plugin-ubuntu-cordova qtcreator-plugin-ubuntu ubuntu-sdk? – Braiam Dec 15 '13 at 8:51
  • I've add the output in edit... – Asim Dec 15 '13 at 20:13
  • 1
    You can't install it in ubuntu 12.04, try ubuntu 13.10 – Tachyons Dec 16 '13 at 3:53
0

I found a way to do it.

  1. uninstall conflicting package: sudo apt-get remove qtcreator-plugin-ubuntu
  2. Download and install required package: 2.8.1bzr56precise0 download here (after download, on double click you should go to Ubuntu Software Center, select install)
  3. install Ubuntu SDK: sudo apt-get install ubuntu-sdk (it will add the cordova needed package)

Enjoy Ubuntu SDK ;)

  • Seems like to have Ubuntu SDK now you just need to install the qtcreator-plugin-ubuntu package: sudo apt-get install qtcreator-plugin-ubuntu – alexscmar Dec 17 '13 at 4:06
  • 2
    This link is broken. Please update. – RolandiXor Jan 8 '14 at 19:34
  • Hi. It's been a while ago, Ubuntu 12.04 has been updated and maybe this package is no longer need to be updated manually. But if you need specific help, feel free to post it. Regards, Alex – alexscmar Feb 10 '14 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.