19

How to make natty boot in verbose mode. Changing option GRUB_CMDLINE_LINUX_DEFAULT="splash quiet to GRUB_CMDLINE_LINUX_DEFAULT="" in /etc/default/grub doesn't effect in natty.

  • 1
    I am not sure, but try it. On the grub options remove quiet. – karthick87 May 2 '11 at 2:20
  • 2
    Did you run "sudo update-grub" after making changes to /etc/default/grub ? – karthick87 May 2 '11 at 2:31
  • @karthick87: Yes, I did it. – kholis May 2 '11 at 10:10
14

Try nosplash debug. If you want output from upstart too, add --verbose

| improve this answer | |
  • can you check to see if these options were passed to the running kernel? cat /proc/cmdline will show you what the kernel actually booted with. – Jeremy Kerr Aug 8 '11 at 5:30
9

Changing

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT=""

in /etc/default/grub is correct, but you also need to run update-grub for it to take effect.

| improve this answer | |
  • The default should be GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" – kevinkayaks Nov 21 '19 at 22:59
2

Hit Esc any time to see the text. For permanent changes, uninstall all plymouth themes, including text ones, and in /etc/grub/default uncomment the line to enable console.

| improve this answer | |
  • 2
    Uncomment GRUB_TERMINAL=console in /etc/grub/default works in my laptop but grub resolution decreased to 800x600. – kholis May 4 '11 at 7:49
  • You can fix resolution right there. GRUB_GFXMODE=whatever. Note that you can use only modes which your graphic card supports via VBE. You can see them in GRUB console with the command `vbeinfo' – Barafu Albino May 4 '11 at 8:18
  • vbeinfo is not found on my system [and apparently isn't in the repo], but this works: sudo hwinfo --framebuffer – Matt Oct 11 '11 at 4:42
  • 2
    vbeinfo is not part of linux: it is a command that you can run from grub screen – user79811 Jul 28 '12 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.