4

I first install Ubuntu 13.10 a few weeks ago and its been going great. I'm still pretty new to Linux, so I haven't been doing a whole lot. The past couple days I've tried installing LAMP, then uninstalled it because I would probably never do anything with it. I then installed SSH, then uninstalled it because I probably would never login to it remotely. Then I install samba so my wife could access the files on my computer from hers and use my PC as a backup.

All is fine and well... until I reboot. I am unable to login. I type my password into the password field, and hit enter and nothing happens. If I type the wrong password in, the little wheel spins for 1/2 second then says 'incorrect password'. With the incorrect password, no wheel shows up - the password field fades away and the screen just sits there. I've waited about 10-15 minutes for something to happen, but nothing does.

I've tried to Google around to solve the issue, but nothing I've seen seems to do the trick. I am able to login through the command line (ctrl-alt-f1) just fine, just am not able to login in through the GUI.

Ive looked at my auth.log and found this:

lightdm: pam_succeed_if (lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "andrew"

I remember seeing something about pam when I was installing/configuring ssh and/or configuring keys for it, but I don't remember specifically what. Plus, I removed ssh shortly after I installed it - so could it still be causing an issue?

I've tried the following:

sudo dpkg-reconfigure lightdm

which says nothing and returns me back to the command prompt

I have tried removing ~/.Xauthority - which didn't help.

My .dmrc file is about four lines. The first two are blank, then [Desktop], then something=Ubuntu

I have tried:

pam-auth-update

everything is checked, doesn't help

and I've tried:

ppa-purge ppa:gnome3-team/gnome3

which doesn't help either.

I've tried renaming my home directory and creating a new one. No luck.

I'm at a loss of what else I can do. Any ideas?

  • When you say "nothing happens" do you mean you stay at the log-in screen? or the screen changes but nothing loads? – virtualxtc Dec 13 '13 at 22:01
5

I have had the same issue a couple of times, appeared to be something corrupted in my user profile. Removing the following files and directory located in your home directory always gives me back my login:

.cache/
.Xauthority 
.ICEauthority

You can do so by switch to a text-based virtual console (Ctrl+Alt+F1), logging in, and running:

rm -rf .cache
rm .Xauthority
rm .ICEauthority

No go back with Alt+F7, log in and (hopefully) be happy again.

  • This worked for me! – user603125 Aug 15 '14 at 23:04
  • please change .ICEAutority to .ICEauthority . Can't make a 2 letter edit. – user603125 Aug 15 '14 at 23:05
3

I was able to fix the issue with help from this thread:

Specifically, with the following commands:

sudo apt-get update
sudo apt-get install ubuntu-desktop
sudo apt-get -f install
sudo dpkg-reconfigure ubuntu-desktop
sudo reboot
0

So I came across this problem 2-3 times before.

Solution to this is simple. Once your free space memory comes close to null, your cache memory and other corresponding memories starts not to respond. So best thing to be done in this scenario is, free up some space from your /home or /opt or /Documents or /Downloads or any software which might take extra space, you should remove it. For this:

  • Press Ctrl+Alt+F1
  • Do login and password
  • Remove some items and thereby create free space (this is just like normal terminal, so you do the corresponding task of freeing up some space)
  • After enough removal of redundant items, press Alt+F7
  • Now, when you login, you will see your normal screen.

Hope this helps.

0

PROBLEM:

This issue occurred for me on Ubuntu 16.04 LTS perhapse because I used following command while researching to solve the issue of graphics not showing 3D menus etc.:

"sudo apt-get clean" or "sudo apt-get autoclean"

and then "sudo apt-get autoremove" when suggested by the system (??)

which i think removed so many basic UI level packages from the system.

WORKAROUND which worked for me:

From recovery mode (boot option) or from login screen press alt+ctrl+F3 to get the terminal.

Install ubuntu-desktop by following command:

sudo apt-get install ubuntu-desktop

In my case I hit the "unmet dependency" or "packages held" problem. To sove it I used aptitude package by following command.

sudo apt-get install aptitude
sudo aptitude install ubuntu-desktop

If not working then, try following commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get update (again)
sudo aptitude install aptitude (again)

check if package is installed successfully by using following command:

sudo dpkg -l ubuntu-desktop

Then,

sudo apt-get -f install
sudo dpkg-reconfigure ubuntu-desktop
sudo reboot

After that, problem should be resolved. (This also solved the problem of graphics 3D menu effect not showing - the hard problem - may be because all basic level ubuntu packages are removed by command "sudo apt-get clean" or "sudo apt-get autoclean" or "sudo apt-get autoremove" and then installed back by "ubuntu-desktop".

Hope this is helpful to others.

-1

I solved the problem by liberating some free space(about 3g). You may cut data stored on your computer from any folder e.g Desktop or Downlload or home etc. Step1: Ctlr+alt+F1 Enter login and password Step2: Connect a pen drive or USB or external hard drive with enough free space(nb:depending on how much data you wish to cut) Sudo fdisk -l (to verify name of storage device) Sudo mkdir /media/usb Sudo mount /dev/sdb1 /media/usb Step3: Sudo mv Download/. /media/usb Sudo umount /media/usb Sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.