1

I'm having trouble setting up a mail server, after following this tutorial I am still unable to send email to anyone outside of my server.

I have installed and configured PostFix, Dovecot, Squirrellmail

The exact error message I get is:

Transaction failed 554 5.7.1 email@example.com: Relay access denied

There could be an issue with my PostFix config file below (mail_version = 2.9.3)

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file = /etc/ssl/certs/smtpd.crt
smtpd_tls_key_file = /etc/ssl/private/smtpd.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache




# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mysite.com
mydomain = mysite.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
relayhost = 
mynetworks = 127.0.0.0/8, 12.33.444.55 #not the real IP
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
home_mailbox = Maildir/
mailbox_command = 
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtp_tls_security_level = may
smtpd_tls_security_level = may
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/ssl/certs/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

Any help would be very appreciated.

  • Unless the machine or network you are configuring this for is exmaple.com that looks like the correct error that should happen when trying to relay mail for that domain. – dobey Dec 13 '13 at 20:48
  • @dobey example.com is an example email, my god, I'm not going to display my real email address. – mk_89 Dec 13 '13 at 21:45
2

You have

mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain

which translates as

mydestination = mysite.com, localhost.mysite.com, localhost, mysite.com

Sending an email to somewhere@example.com is relaying. You can control the behaviour with smtpd_recipient_restrictions. You have reject_unauth_destination which means that relaying is disabled (see here for more details), unless one of the permit_* before matches. In this case you have permit_sasl_authenticated,permit_mynetworks, the second one means you need either to send the email directly from the hosts (in fact any host in mynetworks), or to authenticate yourself (permit_sasl_authenticated).

TL;DR: you need to authenticate if you want to send emails from a remote machine to an other domain.

  • So confusing :-/ wish email was simpler. – Oliver Dixon Feb 1 '16 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.