1
-- [ ERROR ] ------------------------------------------------------
No Xbox or Xbox360 controller found

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 0781:5575 SanDisk Corp. 
Bus 003 Device 003: ID 04ca:0058 Lite-On Technology Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 1bcf:2881 Sunplus Innovation Technology Inc. 
Bus 002 Device 003: ID 0e6f:011f Logic3 
Bus 002 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 005: ID 8086:0189 Intel Corp. 

It doesn't seem to recognize my controller? Can someone help me get this to work?? Xboxdrv won't recognize it and it seems even the computer will not.

6
  • Please print your lsusb with and without the controller plugged in, or at least tell us if it really does not change. Dec 13, 2013 at 19:55
  • This question has no accepted or upvote answers, but it might give you some idea on how to proceed. Dec 13, 2013 at 20:05
  • The above is LSUSB with it plugged in pastebin.com/9aSv55am thats it unplugged
    – Milapurr
    Dec 13, 2013 at 20:15
  • Does it show exactly the same thing without the controller? Dec 13, 2013 at 20:18
  • Yep. I dont know what to do, as for that question, I have no hub, both of the ones I had in the past actually burnt out.
    – Milapurr
    Dec 13, 2013 at 20:20

3 Answers 3

1

Here was my solution.

  1. Download the source code for xboxdrv from here: http://pingus.seul.org/~grumbel/xboxdrv/

  2. I used the 0.87 version: xboxdrv-linux-0.8.7.tar.bz2

  3. Extract it using the tar command in a useful directory:

    tar xvjf xboxdrv-linux-0.8.7.tar.bz2
    
  4. Determine the USB ID of the controller by running watch lsusb and then plugging in the controller. The device should pop up note down the ID. Example: 0e6f:011f

  5. In the src directory find the xpad_device.cpp file. (Not the hpp version!)

  6. Open the file. Inside you should see a list of devices.

    { GAMEPAD_XBOX360,          0x24c6, 0x5000, "Razer Atrox Arcade Stick" },
    { GAMEPAD_XBOX,             0x045e, 0x0202, "Microsoft X-Box pad v1 (US)" },
    { GAMEPAD_XBOX360_GUITAR,   0x1430, 0x4748, "RedOctane Guitar Hero X-plorer" },
    { GAMEPAD_XBOX_MAT,         0x0738, 0x4540, "Mad Catz Beat Pad" },
    
  7. Copy one of the entries and modify it to reflect your controller.

    { GAMEPAD_XBOX360,          0x0e6f, 0x011f, "Rock Candy Gamepad for Xbox 360"},
    
  8. Install required libraries for compilation. For other distros these may be different. This list can also be found in the README.md file included with the tarball.

    sudo apt-get install \
      g++ \
      libboost1.42-dev \
      scons \
      pkg-config \
      libusb-1.0-0-dev \
      git-core \
      libx11-dev \
      libudev-dev \
      x11proto-core-dev \
      libdbus-glib-1-dev
    
  9. Uninstall xboxdrv if you already have it installed.

    sudo apt-get remove xboxdrv
    
  10. cd to the extracted xboxdrv directory and run scons.

    cd /home/foxyv/Downloads/xboxdrv-linux-0.8.7
    scons
    
  11. After scons is done configuring the build, run make.

  12. When make is finished building, run sudo make install to install the compiled application.

  13. Plug in your controller! You may need to restart the xboxdrv daemon using sudo service xboxdrv restart

2
  • could not install libboost1.42-dev, had to use libboost-dev, that worked. Everything went fine until I attempted to restart the xboxdrv service, I got "Failed to restart xboxdrv.service: Unit xboxdrv.service not found." Should this all have been done in a specific directory?
    – Bus42
    Sep 4, 2017 at 18:45
  • This can be done in any directory. The make install should install the source code to the correct directories automatically as long as you have sudo access. You may want to re-attempt the installation if the service hasn't been installed. Oct 3, 2017 at 17:26
0

Try the steps from this post. Basically it involves two steps:

  1. Installing xboxdrv from a PPA which contains a more updated version of the package: sudo add-apt-repository ppa:grumbel/ppa && sudo apt-get update && sudo apt-get install xboxdrv
  2. Blacklisting the xpad driver by adding blacklist xpad to your /etc/modprobe/blacklist.conf
5
  • Done that, not recognizing the controller still.
    – Milapurr
    Dec 13, 2013 at 19:59
  • Are you using it for Steam or something else? I ask because I have a first-party wired 360 controller which worked out of the box in Steam. When I installed xboxdrv, it stopped working on Steam. Dec 13, 2013 at 20:01
  • Its a thirdparty 360 controller, its called rock candy and Im using it for Minecontrol for minecraft. It used to work fine when I used Afterglow which was made by PDP
    – Milapurr
    Dec 13, 2013 at 20:03
  • 1
    Found out, logic 3 is the controller. Which was weird.. So I ended up finding a fix... but it still doesnt work so I guess it doesnt matter. I cant run xboxdrv in silent... and the buttons don't work at all in game.
    – Milapurr
    Jan 2, 2014 at 6:57
  • I'd recommend you add that information to your original post so other members can better find it. I'm sorry I can't help you further, but I really hope you find a solution. Have an awesome 2014! Jan 3, 2014 at 0:26
0

I tried long and hard to get xboxdrv to work with this controller. I recompiled the source code but it would crash. The driver built into the kernel worked but it wasn't loading by default. That was an easy fix.

I just had to run modprobe xpad as root. When I unplugged the controller and plugged it back in, it lit up.

To make it start on boot make a file in /etc/modules-load.d/xpad.conf with the contents xpad and make sure the systemd-modules-load.service is enabled with systemctl.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .