10

I've tried various workarounds, but I haven't yet found a way to make the fonts in Netbeans look right. I've tried changing the config files of Netbeans, and trying the instructions here that don't seem to have any effect since they aren't installed in 13.10.

My specific question has three parts: 1) why is every font 18 or less drawing characters with lines that are only one pixel thick, and the . and : are making only one pixel on the screen - unless I force bold, or a huge font of 19 or more:

(If this is a Java problem, why is Eclipse fine?)

Bad font, thin and not easily readable Bad font, thin and not easily readable

Almost okay font - but HUGE: Almost okay font - but HUGE

If you look at the terminal or native Ubuntu apps they don't show up as only one pixel - is there a solution for this?

2) Why does Netbeans show a box at the end of the line, when text is too long and overflows to the next displayed line?

3) Maybe not related, but why do popup-windows of Netbeans have this small dropdown below them? This happens both with the netbeans-starting info window, and the git changes popouts from the bar with the line-numbers.

Ugly Netbeans dropdown

Ugly git integration showing changes:

Netbeans Git dropdown

Update

No change in 8.0, unfortunately :(

1
2
+50

1. Fonts

I searched a bit on this issue, but I didn't find a way on how to make the fonts "bolder". The issue does not seem to be Ubuntu 13.10-specific however. The link you refer to is about another bug, that actually makes some text a bit thicker. (see below)

I did find some things that can help you, I do not know if you will find them better, feel free to try them.

Make it use system fonts in menu and other places

This bug actually makes a lot of the text nicer in my opinion. Just sudo apt-get install fonts-unfonts-core and restart netbeans. (only works with JDK7) It will look like this:

Buggy font

However, this does not change the editor font.

Change theme

Changing the theme changes the fonts a bit, however, it does not make them thicker.

gedit ~/netbeans-7.4/etc/netbeans.conf

And add --laf Metal to the netbeans_default_options

The default theme is "GTK". I like "Metal" myself. you can find a complete list of themes on the netbeans website

Metal Theme

Other options

i have not tried it out myself but this answer seems promising. Let me know if it looks better...

2. Overflow

I do not understand what you mean. Maybe a screenshot would help?

3. Weird windows that have wrong size, wrong shading

Seems to be a bug in java. If i use JDK6 it is actually way worse...

2
  • Can I have JDK7 and still use the Android SDK? I attached another screenshot, see updated question. – NoBugs Dec 24 '13 at 1:44
  • I do not think it would be a problem. If it is a problem, you can always just remove JDK7. – Merlijn Sebrechts Dec 24 '13 at 8:34
0

If you want to keep using gtk+ theme, there is a solution that is already implemented by default on ubuntu 15.04 which fixes the menu on java swing applications.

sudo add-apt-repository ppa:danjaredg/jayatana
sudo apt-get update
sudo apt-get install jayatana
0

For the ugly fonts part, there is a solution. add the following code into the end of the default properties section in the netbeans.conf file.

-J-Dawt.useSystemAAFontSettings=on
-1

Go to Tools > Options. Select the appearance tab and choose the preferred look and feel to Metal. See if it fixes the theme and fonts.

If you like to have a darker theme, go to Tools > Plugins and install "Darcula LAF for NetBeans".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.