Ubuntu: 13.04 - raring
Exchange: MS 2007
Thunderbird: 1:24.1.1+build1-0ubuntu0.13.04.1
Evolution: 3.6.4-0ubuntu1
Evolution-mapi: 3.6.2-0ubuntu1
Evolution-ews: 3.6.1-0ubuntu1

My company uses exchange for Mail and also has a 'brand style' email template and signature. I can't seem to find a good Linux solution that allows both to work to company standards.

The Company's Brand formatting

It is essentially a Calibri font/sans-serif; font size:11.0pt; colour#1F497D. Any Linux mail I use must be able to default to that when I write a new message, forward or reply.

This has been set up because the rest of the company uses outlook.

Initially I had hoped to use Thunderbird, and bought an ExQuilla licence which sync's perfectly (though slower than outlook). However the colour #1F497D isn't one of the default swabs for colour choices avaible under Preferences>Composition>General>HTML>Text Colour. I could get the right colour by manually copy pasting the Hex code into the colour selection tool in the write window... but this was fiddly and requires me to keep the hex code constantly on hand... Instead I installed last colour picker, which jumps to the last swab I used. More useful... but still not ideal.

Evolution offers a one up in this respect, I think I can here customise the composition look of my email as per company standards... so I looked to move...

Exchange Server 2007 settings

This guide initially looked very good. So i aimed to install evolution and MAPI.

sudo apt-get install evolution
sudo apt-get install evolution-mapi

And so I installed Evolution and Evolution support for the groupware suite. I quickly found I couldn't select the correct protocol, however this was resolved by installing the missing dependency, as per this solution via:

sudo apt-get install python-samba

This seemed to be working better. I made an account as follows using the evolution account assistant, I've included dummy names.

Full name: Joe Blogs
Email Address: [email protected]

The MAPI attempt

So first I tried setting Server Type under 'Recieving Email' to Exchange MAPI.

For configuration my server settings were initially:

server: exchange.mycompany.co.uk
username: joeb
domain name: [empty]

So i entered domain name in as "mycompany.co.uk"... Authenticate... entered by (definitely correct) password. However in the Mail authentication request box it rejects the password and says Password is incorrect.

I've juggled with these heavily trying my owa address which is along the lines of mail.extention.ourcompanymailserver.net/owa... no joy.

So I went back over to thunderbird and the working server address I had tied into thunderbird: https://mail.extention.ourcompanymailserver.net/EWS/Exchange.asmx

Following the thread here I tried by exchange address, still no joy. This site again suggested I used my server IP address... however I don't know that and there's no sysadmin to help us here!

I figured I could just ping the server

ping https://mail.extention.ourcompanymailserver.net/

which came back with an IP that I then stuff into evolution.. no joy.

I then noticed there was an evolution EWS module. which I installed

sudo apt-get install evolution-ews

Which seemed to get me further, now I could get through the initial install and appeared to get a working setup, but a sync from my server wasn't forthcoming

an EWS_DEBUG=2 evolution gives me lots of

"(evolution:16603): Gtk-CRITICAL **: gtk_entry_set_text: assertion `text != NULL' failed"

Sadly turned up nothing on Google...

And so I'm stumped. I can't seem to move to Thunderbird because it won't customise my email in a way that suits my company... and I can't use evolution because of exchange issues...

It be great to get this setup as my entire home setup is Linux... and I have quiet designs to get more of my colleagues to shift given their windows 8 frustrations!

Any advice on resolving this... or a smarter point of intervention (Thunderbird?) would be much appreciated!

1 Answer 1


I have finally found a solution. To be clear this does not solve my problems with Exchange and Evolution but is a workaround that allows me to use Ubuntu Linux with my business email!


  • Thunderbird
  • ExQuilla plugin (please not this is now paid for on Thunderbird v24+ since November 1, 2013, at time of licence purchase in 2013, this was US$10)

You then need to edit the msgcompose.text_color in the about:config section.

Many thanks to Sanil Kumar for his solution found here:

In Mozilla Thunderbird, normally we can change write(compose) window Text color by picking color from Text Color window or we can give any costume color by putting HTML color code or String name.

But this color will only effect the current Write window. Next time Text color will be the default color. we can set permanent Text Color through the Menu Tools->Options.

Select composition tab from Options Window. Select Text Color in HTML option of General Tab. Color which you selected from this option is permanently set for all Write window. But unfortunately we can't provide custom Color on this option.If you still need to provide a Custom Text Color for all Write window then you have to follow these steps on your risk.

  1. Select Options from Tools Menu
  2. Select General Tab under Advanced Tab of Option Window
  3. Click Config Editor button
  4. Click on "I'll be careful, I promise!" in about:config windows warring message to continue
  5. Type Text and Hit Enter in about:config window Search box
  6. Double Click on "msgcompose.text_color"
  7. Enter you Custom Text Color HTML Code in msgcompose.text_color box and Click OK Button
  8. Close the about:config and Pick a new Write window and Type some text and check your Text Color

This will set your custom Color as Default Text Color for Write Window

This allows me to receive exchange emails to Ubuntu and customise the email style to fit with my Companies in-house standards. They are now indistinguishable from those I send with (errgh) outlook.

  • Update: March 2016 | I've now switched to N1 which is awesome
    – Huw
    Commented Mar 19, 2016 at 13:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .