I cannot get Ubuntu 13.10 64-bit ISO installed on a Lenovo Ideapad U330p (i5 core, SSD) preinstalled with Windows 8, by using a Ubuntu USB live stick.

  • I tried various live usb creators (the build-in one crashes, but the rest Live USB Creator, mkusb script, etc work ok).
  • I tried also with various UEFI / Secure boot options in bios (no secure boot, no uefi = legacy), with no luck.
  • I tried also with EFI, and without the EFI folder on the USB and legacy bios install, no luck.

The most I can achieve is to get the Ubuntu live usb first screen with the Ubuntu options shown, but then with any option I choose (Try, or Install) after a few seconds I am left with a black screen, and nothing happens, no matter how much I wait. I have then to power off the machine.

I am not sure this is related to UEFI, but it does not seem like.

Does anyone has any experience with this type of machine - Lenovo Ideapad U330p?

Preferably, I would like to get rid of the preinstalled copy of Windows 8 completely and install only Ubuntu there (I do not want a dual-boot system, but I can live with dual-boot system if than is the only way). Any install mode (legacy or UEFI, MBR / GDI) will do.

Update: Some details (I have read all relevant ubuntu/uefi related links here, and in ubuntu wiki):

  • I disabled win8 fast boot and hibernate
  • I have disabled secure boot
  • I tested with uefi and also with disabled uefi (legacy)
  • I tried with Ubuntu usb with EFI folder, and renamed EFI folder
  • I tried with various programs to create the Ubuntu USB

With some of these combinations it does not work, but with UEFI and secure boot disabled - I see the grub-like menu, and without UEFI at all I see the boot screen with options. However, no matter what option I choose, it freezes (screen becomes black after one second or so after that), and only the power off button works. Some people say this is graphics driver issue (for other models) - but would be nice to know if someone has any experience with my model.

Some of the links I read:

https://help.ubuntu.com/community/UEFI Installing Ubuntu Alongside a Pre-Installed Windows with UEFI http://elabualg.wordpress.com/2013/10/22/dual-boot-ubuntu-and-windows-8-uefi/ https://askubuntu.com/questions/260793/uefi-boot-results-in-a-black-screen Dual boot problem, black screen during the ubuntu boot UEFI 13.04 install on Lenovo IdeaPad Y510p boots Windows instead

  • i'm using lenovo z500 laptop,change UEFI to legacy in bios,then boot from live-usb.It will works. – Avinash Raj Dec 12 '13 at 11:30
  • did you select usb from the boot menu in bios?Which software did you used to create live-usb? – Avinash Raj Dec 12 '13 at 15:06
  • See askubuntu.com/questions/162075/… as well. – user68186 Dec 12 '13 at 15:43


Thank you all for your suggestions, after reading some more similar reports, it turns out it was simpler than I thought. After selecting the Try or Install, the screen brightness was set to 0. So I could see only pure black. Using the laptop brightness keys worked and the live Ubuntu is working fully ok. A bit stupid, but the screen was so black, I did not to came to the idea of using the brightness buttons (one has to press it two-three times before one can see the light on the screen).

To answer some of the questions:

  • For the usb, I tried Unetbootin, usb-creator-gtk (crashed), Live USB Creator, and mkusb script from http://ubuntuforums.org/showthread.php?t=2172971 on Ubuntu. The current usb I used for the last test is the one created with mkusb script. May be the others have worked too, but I could not tell.

  • I disabled secure boot in bios, and I changed the boot menu order in bios. In U330p bios can be reached via the small nova button - I am using a small screwdriver to press it.

  • After Try Ubuntu without installing from the grub, one has to use laptop brightness key to see the screen.

So I will install Ubuntu next :), thanks for all the help.


I can't comment, so sorry if this isn't a perfect answer:

I believe the problem is that Secure-boot is enabled in your BIOS settings. Turn it off and you should be able to do an MBR, UEFI, and possibly even a secure boot install.

If that doesn't work try disabling power management, At the Grub2 boot loader screen choose the kernel you want to boot and press 'e'

go to the end of the line and add / edit the line to include:


Regards, Jason

  • Thanks, I tried it with secure boot disabled without any success. The Ubuntu grub-like screen does come and you can select entries (Try or Install), but after that the screen becomes blank. – ppp Dec 12 '13 at 14:49
  • I mean the screen becomes black. It does not respond to any key press (esc, etc). Only power down works. – ppp Dec 12 '13 at 14:58
  • Oh, just to be clear, you are booting off the usb stick, and haven't yet preformed an install correct? If so, try the steps outlined in my updated answer. – virtualxtc Dec 12 '13 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.