8

I followed the NBR2MP4 converter procedure on the WebEx site and also reviewed the step-by step instructions at https://askubuntu.com/a/362719/219130 but no matter what I do, it just doesn't work (i.e. doesn't output any MP4 file).

From within the nbr2_mp4 directory:

$ ./nbr2mp4 my_file.arf /tmp/ 5
Converting /home/username/nbr2_mp4/my_file.arf to /tmp/my_file.mp4
Retrieving video data, fps=5...

I tried many different options with or without DEST and FPS, with and without sudo, and whatever I do, it just doesn't output any file, ever.

On the WebEx site it says Linux OS: 32-bit Ubuntu 8.10/9.04 so it might simply be that the scripts are incompatible with 13.10, but I'd rather know if others have the same issue too?

4

In my case, in Ubuntu 16.04 AMD64 I still needed these 32-bit libraries:

sudo apt-get install libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libgtk2.0-0:i386 libasound2-plugins:i386

I found out which libraries I needed by

  1. trying to run ./nbr_play

  2. looking for the missing library with dpkg -S (e.g. dpkg -S libpangoxft-1.0.so.0)

  3. installing the library in its :i386 version.

But that was much more difficult than just downloading the windows player msi from https://www.webex.com/play-webex-recording.html and running it inside wine (and I still receive an mmap allocation error):

wine msiexec /i path/to/nbr2player.msi

The program is called Network Recording Player and should end up in your application menu.

2
  • I can get the nbr2mp4 to work, but need to wrap it with xvfb-run since it's on an Ubuntu server with no display. However it runs extremely slowly. Did you need to wrap it with xvfb-run as well? – Anonymous Oct 5 '17 at 6:23
  • No. I used it in a real X environment. I don't recall whether it was hanging or slow. – Dej Feb 22 '18 at 7:52
4

nbr2mp4 converter comes with the libraries it requires but doesn't read them from the directory.

Just run

export LD_LIBRARY_PATH='./'

to let nbr2mp4 'see' it's own libraries.

Then the converter can be run as

nbr2mp4 XXX.arf

To make sure that the conversion is in progress check if one of /tmp/wbx_nbr*.h264 files size is increasing.

Tested on Ubuntu 16.04 64bit

2
  • 1
    I installed nbr2mp4 in /opt/ directory, have the same issue as OP. Then I did what you've written here, but it didn't help. I don't see any output file, I don't see any file in /tmp/ directory, like nbr2mp4 still doesn't work. – kujaw Jan 17 '19 at 13:09
  • After installation of libraries which @Dej has written in his answer, nbr2mp4 works. However, I have a .wrf, not .arf file and receive error saying "Cannot convert recording file because it is not a valid file format. Specify an Advanced Recording Format file (.arf)." – kujaw Jan 17 '19 at 14:23
3

I had the same problem. In my case, some libraries required by nbr_play (the actual binary executed by nbr2mp4->nbrplay->nbr_play; nbr2mp4 and nbrplay are shell scripts). Just installing the missing libraries solved the problem.

You can check for missing libraries with 'ldd nbr_play'.

Also be aware that nbr_play is a 32-bit program. If you are using a 64-bit system, there is a chance that you already have installed the 64-bit versions of the libraries but not the 32-bit versions. In such a case you must install the 32-bit version of the libraries too.

The reason why the linker errors (unresolved libraries) are not shown when you execute the command is because the errors are redirected to /dev/null in the shell scripts mentioned above.

0

There is no need to install nbr2mp4 , which anyways didnt work on my Ubuntu 18.04 bionic. To Play .arf file , do following

1> Download nbr2player.msi (yes, windows installer) from webex link above or google it.

2> Right click and choose Open with option and then choose , "Find New Applcaition"

3> Ubuntu will suggest Q4Wine for the application, install it.

4> Now have your, Q4Wine know the path of downloaded msi file and install the nbr player.

5> Open nbr player using super key and browse to arf file and viola, play it.

Additional optional step : Above steps works, but in case dependencies were still missing for Q4wine , install winetricks

sudo apt-get install winetricks

Retry 5 steps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.