5

Every time I run shotwell 0.15 (Ubuntu 13.10), it starts scanning my entire hard drive (according to ~/.cache/shotwell/shotwell.log) and displays "Updating Library." Is there a way to prevent this full-drive scan at startup? All my photos are in one directory tree and there's no need to scan elsewhere.

I checked the shotwell manual but didn't find a solution.

I tried invoking shotwell with the --no-runtime-monitoring option, but this made no difference.

I deleted ~/.cache/shotwell and ~/.locale/share/shotwell and reran shotwell, but this made no difference.

This thread asked the same question in 2012, but it did not provide a solution:

This bug sounded relevant at first but seems to be about a different issue:

Thanks for any insights.

  • How about going to Edit->Preferences->Library (tab) and Uncheck watch library directory for new files. Hope that helps, – ASCIIbetical Dec 12 '13 at 4:10
  • 1
    Sorry, that checkbox makes no difference. The full-disk scan happens anyway. – DanB Dec 12 '13 at 12:25
  • Looks like this answer relieves the symptom, sort of. shotwell scans its "Library Location." If I set it to the actual directory containing my photos, it scans only that folder instead of the whole disk. I don't see any way to prevent the scan at startup though. – DanB Dec 12 '13 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.