Iftop is what I downloaded to see my daily internet usage of my computer or any other computer on my LAN (ie bro and sisters usage). I want total MB's/day from each computer. so I installed and ran sudo iftop and I get a screen just like the website says I should except, no domains or IP's or anything, its an empty chart. Is there a command I have to tell it to monitor my local network? I know there's activity I am surfing right now. Yes I read the webpage, no I did not glean a how to use, so it must be that "common knowledge" thing I am missing.

  • You are using wired or wireless? And I think for your purposes vnstat is needed, not iftop. – falconer Dec 11 '13 at 21:10
  • thanks Jack Jefferson this worked with me it was sudo iftop -i wlp2s0 – elswerky May 13 '17 at 1:14

iftop display Network Interface Bandwidth Usage. To install iftop if not installed, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install iftop

By default iftop command displays the bandwidth usage of the first available Ethernet device.

sudo iftop

Or you can also specify an interface using the -i option.

sudo iftop -i eth0

While iftop is running, you can press any one of the following keys to display more output.

S - display source port
D - display destination port
n - show IP instead of host name
1/2/3 - sort by the specified column
< - sort by source name
> - sort by destination name
P - pause display ( else it will be often updated to show the current status )
j/k - scroll display
? - for help

The image below shows the different arguments (options) that you can use with iftop.

enter image description here

Iftop is probably set up to use a different network interface. Run the command ifconfig to see your connections. Then if, for example, your connection is named eth0 run the command sudo iftop -i eth0. Hope this solved your problem.

  • this worked, thank you Jack Jefferson. and thank you Mitch for taking the time to respond. "sudo iftop -i wlan0" gave the desired result. also used the "-p" option. Now all I need to know is how do I do the highlighting code that shows the commands like you do. – user129041 Dec 12 '13 at 6:06
  • code is typed with a ` either side. That's the key above tab (on a standard UK keyboard), not an apostrophe. – Jack Jefferson Dec 12 '13 at 17:41

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.