0

I have installed ubuntu 13.10, and have difficulty in mobile boradband. I have a Tata Photon usb stick, configured as Huawei EC 1260. It shows up in lsusb as 12d1:140b, but does not show up as device when I try to add a mobile broadband connection. It also does not appear in network manager icon.

  • to install huawei modem drivers askubuntu.com/questions/368294/…. NDIS driver problem see this askubuntu.com/a/368669/202806 – Avinash Raj Dec 11 '13 at 16:26
  • @ Avinash Raj - that may be a solution, but Ubuntu already has a generic mobile broadband driver which works flawlessly ONCE the device mode is switched. Somehow it's mostly Huawei/ZTE dongles which refuse to switch. – Pavel Dec 11 '13 at 18:01
0

Your dongle is supposed to switch into modem mode automatically but it doesn't. The problem is similar to mine: Huawei e173s 3G USB dongle won't switch into modem mode - except that the device is different, and so may be the exact cause.

The program which does auto-switching is usb_modeswitch. The first thing you should do is to enable usb_modeswitch logging: http://www.draisberghof.de/usb_modeswitch/#trouble (that section also suggests some common problems/solutions).

After looking at the log file, you will be able to localize the problem and cross-check with forum threads such as this: http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=681

Unfortunately, I can't give you an exact answer to the problem as causes may vary depending on device type / firmware version / kernel version; but above should constitute a reasonable troubleshooting guide. You can follow the steps and write back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.