3

i'm using a wireless adapter TP-Link TL-WN725N with this driver and wireless signal is extremely low in ubuntu 13.10 and barely loads google. Thought no problems with it in windows.

How can i fix it?

wlan1     IEEE 802.11bgn  ESSID:"Iarna"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.427 GHz  Access Point: 64:66:B3:AF:CC:9A   
          Bit Rate:150 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=0/100  Signal level=2/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
2

In my experience with TL-WN725N Dongle I thought it was the firmware from Git or the stock linux-firmware that comes from ubuntu to be problematic, but I followed this guide from http://linuxforums.org.uk/index.php?topic=11261.0 to retrace my steps and then I tried something different that I didn't believe that it will work, but it seems there is a conflict between these modules r8188eu and 8188eu and then what I did was:

I added this line: blacklist r8188eu

In

sudo gedit /etc/modprobe.d/blacklist.conf

Save and Quit from Text Editor

Then in

sudo gedit /etc/modules

I added this line at the end of the configuration: 8188eu. Save and Quit from Text Editor again

Then you do

sudo depmod -a
sudo update-initramfs -u

And before you reboot the system it is important to test these commands:

Check if the module you already blacklisted with

lsmod | grep r8188eu

If it's not removed then remove it with

sudo rmmod r8188eu

And finally you do

sudo rmmod 8188eu
sudo modprobe 8188eu

To refresh the module and you'll have a working with full signal wireless

Reboot!

Let me know if you have working wireless because there isn't any workaround like this in (Forums/Wikis/Unofficial Blogs) and it's tested by me and it's working perfectly.

You may notice that Network Manager is not showing you signals on the other wireless protected networks, but if you connect to the other wireless networks via WPA Key it will work as it should.

Enjoy!

| improve this answer | |
0

I had a similar problem with the v2 of this dongle:

Bus 001 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.

I had very low signal, hardly possible connect and 1000+ of ping on the local network on Ubuntu 14.04 running on Samsung ATIV 9, 2015 NP930X2K, (the wifi embedded card is not yet supported so I plugged this small TP-LINK wifi dongle). The packed driver with the distribution is

[r8188eu]
filename:       /lib/modules/3.16.0-34-generic/kernel/drivers/staging/rtl8188eu/r8188eu.ko
version:        v4.1.4_6773.20130222

I followed the same approach as in the first answer but I used the more recent branch of the driver. The git command have to be changed to the following.

git clone -b v4.1.8_9499 git://github.com/lwfinger/rtl8188eu

There is no issues during compilation and installation and the device works!

| improve this answer | |
0

I had exactly same problem on Debian, while on Windows everything worked fine. In my case I found out that I had to install drivers from official site.

  1. I downloaded the archive for Linux and unpacked it
  2. Removed current drivers with sudo rmmod 8188eu
  3. Built downloade drivers with sudo make - for some reason the simple make threw lots of errors
  4. sudo make install
  5. sudo modprobe 8188eu
  6. Reboot

In case the module is not loaded automatically after reboot, you may need to check if it is present in /etc/modules as @mikhail suggested.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.