I have installed windows 8 in the partition sda4 (and ubuntu 12.04 was pre-installed) - partition screenshot below - and then tried recommended repair using boot-repair. But after boot-repair, Grub does not detect Windows. I've tried to repair grub twice (using boot-repair), but no gain.

(Earlier I installed windows in logical partition but now, it is in primary then why it doesn't get detected by grub?)

GParted screenshot

So far I've tried these...

Contents of grub.cfg - updated (Please note that this file is in the directory /boot/grub and NOT in etc/grub. In fact, there is no such directory like etc/grub.)


Also, if it may be related to the problem in any way... Ubuntu does not show the 101GB (NTFS in which Windows is installed) partition in the devices and gparted shows an exclamation sign beside this particular partition, asking to run chkdsk /f on windows and rebooting twice (this was not shown while I was on LiveCD) but I am able to successfully mount this partition using terminal.

More info (if it may help with another question): Initially the /home was around 246GB and I shrank it to 146GB and installed windows in 100 GB (logical partition). Later when I got to know that windows won't boot from logical I managed to move that 100GB (after deleting it) out of extended by moving the 100GB unallocated space to bottom and decreasing the size of extended partition.

I installed windows in this (now) Primary partition and repaired grub. But grub didn't show windows loader option. So I again repaired windows boot loader. Now here I got two windows options, Windows 8 and windows 8 on volume6. The earlier is the option for the windows which I earlier installed when that was a logical drive. My (second - it is not related to Ubuntu though) question is why and how is windows boot loader is getting info about the previous installation of windows as I had deleted the partition later.

  • is that you can be able to boot both windows and ubuntu. Dec 12, 2013 at 13:01
  • I want that, but I am unable to do so.
    – Tarun
    Dec 12, 2013 at 13:14
  • I am not saying that it's not the answer, I'm just saying that the ultimate purpose (of dual-booting) has not yet been met. Now I've made it a primary partition as you said but still can't dual-boot.
    – Tarun
    Dec 12, 2013 at 13:42
  • still you can't able to dualboot? Dec 12, 2013 at 13:45
  • That's what I'm saying. I told so in that question also.
    – Tarun
    Dec 12, 2013 at 13:47

2 Answers 2


This brought so much memory for me from the past which often happened to me.

The fix that worked for me: use your installation cd and start the system off from it.

Select the option from menu, "Rescue the broken system"

You will go through the cycle of series of questions which it would lead you to partition section. When you arrive to that section, escape the process. You then will see the menu and you should see "Install GRUB".

Re-install GRUB and be sure to install on your master HD (sda1)


You will then see your GRUB back and it'll detect your dual OS between Win and Ubuntu.

EDIT: Found this article for you: https://sites.google.com/site/easylinuxtipsproject/tips#TOC-Make-Windows-the-first-option-in-the-Grub-boot-menu

  • The solution that you are giving (what I've understood) is to re-install grub. That's what boot-repair does! But it didn't work.
    – Tarun
    Dec 11, 2013 at 10:20

Okay. I can't get from you question whether are you able to boot into ubuntu after you did a boot-repair from the Live CD? If you can do that, then do it. Then boot up the installed ubuntu system, and run sudo update-grub from the installed system. After that check whether you can boot into windows and ubuntu. If you can, problem solved, if you can't then update your question with your /boot/grub/grub.cfg from your installed ubuntu system.

  • There is no folder like grub. The only folder related to grub is grub.d but it does not have any file named grub.cfg. I found the file grub.cfg on searching the file system in /boot/grub whose contents have been added in the question.
    – Tarun
    Dec 17, 2013 at 20:23
  • @Tarun Of course. I missed typed it. Sorry.
    – falconer
    Dec 17, 2013 at 21:15
  • I tried that chkdsk /fand gparted didn't show the exclamation sigh anymore (But it doesn't show it in the devices even now) but after doing that and updating grub, I still can't see windows loader option in grub.
    – Tarun
    Dec 18, 2013 at 15:32
  • Sorry but I didn't understand your UEFI OS selection advise. Could you please elaborate it a bit more.
    – Tarun
    Dec 18, 2013 at 15:33
  • @Tarun I was referring to this about the UEFI OS selection. So maybe it is possible to change which OS you want to boot in the UEFI firmware. (Although I have never seen this in practice, thats why I don't know whether it is possible.)
    – falconer
    Dec 18, 2013 at 19:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .