Yesterday I upgraded to 11.04 and I found out the new Linux kernel 2.6.38 did not work. The maverick kernel however did. Searching at askubuntu I found some tips which suggested to disable quiet splash in the grub config (/etc/default/grub).

I supposed it had something to do with the video driver, so I disabled the nvidia proprietary driver and rebooted. This didn't really work and eventually I ended up with a the non-graphical tty1.

With startx I tried to start the graphical environment again, but this resulted in an error like:

Failed to load module "nvidia" (module does not exist, 0)

After that I booted in recovery mode and reinstalled the nvidia driver again, after the classic gnome worked again, but Unity doesn't work yet. Also in classic all (compiz) effects are disabled.

I guess I have to get that working again and Unity will work after that too, question is: how?

  • I also tried compiz --replace (and unity --replace) which had this output: pastie.org/private/ula73fntuxl9wvht7kkug It looks like opengl is failing. – arian May 1 '11 at 19:33
  • It seems I'm using nouveau now, which doesn't really work with compiz yet... I didn't mange to switch to nvidia properly though. – arian May 1 '11 at 20:46
  • I tried these steps: help.ubuntu.com/community/BinaryDriverHowto/Nvidia but I cannot find the linux-headers-2.6.35 in the repository anymore. I'm using that kernel because the 2.6.38 didn't boot at all. – arian May 1 '11 at 20:48
  • Why 2.6.38 didn't boot? What are messages in console and logs? – Extender May 3 '11 at 5:18

I struggled for a while in a similar spot. Ulimately my problem was that I hadn't installed the latest Nvidia drivers like I thought I had. Execute the following:

$ cat /proc/driver/nvidia/version

NVRM version: NVIDIA UNIX x86 Kernel Module 270.41.06 Mon Apr 18 14:54:25 PDT 2011 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)

If you are seeing 173 or 185 in the output, you have an older version of the Nvidia driver installed. Older versions don't work that well - I found that out the hard way.

If this is your problem, launch "Additional Drivers" via the Gnome/System->Administration menu. It should allow you to choose to install the "current version". Choose to do that.

  • I think it will not work with 2.6.35 kernel – Extender May 3 '11 at 5:17

I'm thinking compizconfig-settings-manager is the package you're looking for...

  • I already have ccsm installed, and the Unity and other plugins are all enabled, so I don't think that's it. – arian May 1 '11 at 19:03

I had a similar problem where Unity wouldn't work but Gnome would. I resolved this by logging in under Ubuntu (unity) and then pulled up ccsm. In ccsm disabling Gnome Compatibility and enabling Unity worked for me. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.