0

I ran sudo update-rc.d celeryd defaults

All good.

I ran:

/etc/init.d/celeryd start

All good.

I restart machine.

All bad.

sudo /etc/init.d/celeryd status

celeryd not running (no pidfile)

I'm a noob on linux and I don't even have the first idea of where to look to find some error messages. I checked /var/log but I don't see anything relevant. /var/log/celery is empty. But if I manually run celeryd start, then /var/log/celery will have some logs.

2

Here's the process.

  1. Put the celeryd file inside /etc/init.d/
  2. Make it executable

    sudo chmod +x celeryd
    
  3. Make it run on startup

    sudo update-rc.d celeryd defaults
    sudo update-rc.d celeryd enable <------- Are you currently missing this step?
    
  4. Make it owned by root and have the correct permissions

    sudo chown root:root celeryd
    sudo chmod 777 celeryd
    
| improve this answer | |
  • 1
    sudo chmod 777 celeryd 777 for an executable? Are you serious? – ilhnctn Mar 28 '18 at 7:20
0

You need to tell the system to auto start it. Read these excellent answers on the different ways you can achieve this.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.