5

I started with Linux for about 4 or 5 months, moved from Mint 15 to Ubuntu 12.04 and I'm loving it all. Still getting used to terminal commands and the variety of software I can find here.

I currently have a Let's Play Channel on Youtube, so, I need to record gameplay footage (video and audio) along with microphone audio (in a separate file, with audacity).

I found a software called Simple Screen Recorder (SSR) to record gameplay video and audio footage, I have checked the website for instructions on how to adjust the things and the problems began.

First, the video is recorded just fine, it's the simplest software I could find to set up the configurations and get it up and running. Problem is, no gameplay audio, no system audio. Audacity records the microphone just well, so I started to take a look on the configurations on PulseAudio Volume Control while recording something with SSR. Many tutorials tell to change the audio imput to Monitor of Built-in Analog Audio in order to record the gameplay audio, but this did not work to me here.

I suspect that this Monitor of Built-in Analog Audio is not configured or that it does not have audio to be recorded at all, how can I fix this?

Thanks you for your attention!

5

I don't know how far you got in this process, so I start from the beginning:

  1. Install pavucontrol:

    sudo apt-get install pavucontrol
    
  2. Launch it:

    pavucontrol
    
  3. On the Input Devices tab select Show: All input devices
  4. Check the Volume level and if necessary Unmute the Monitor of Built-in Analog Audio channel by clicking on the little speaker icon.
  5. Launch Audacity, start recording
  6. While Audacity is recording: In the pavucontrol Recording tab change the Input Source for Audacity to Monitor of Built-in Analog Audio

Did that help?

  • Is pavucontrol necessary in order to enable "Monitor of ..." devices? Or is there a way to just enable it through the standard pulseaudio tools like pacmd or pactl? – CMCDragonkai Feb 29 '16 at 7:54
  • Great, the steps number 3 and 4 helped me fixed the same issue on Ubuntu 14.04. Thanks! – Louis Gagnon Jan 12 '17 at 12:44
0

My experience was with Audacity, had worked easily enough in previous Ubuntu versions. I'm now using 10.14 LTS. I installed the pavucontrol, and soon got it working. Not without fiddling with a few things. See below

Make sure you go to Configuration in the pavucontrol tool. I had to select "Analog stereo ouput". Then go to Audacity and choose Pulse Pulse Video:0, in the main panel of Audacity. Then I was able to record. Thanks for this post!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.